lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-23-2012, 04:20 PM   #41
Getting Wild
Club Car
 
Join Date: Dec 2011
Posts: 76
Default Re: 2004 Precedent with new batteries going slow

Update : Diagnosed as bad battery. After 3 holes of golf voltage dropped to below 11V. All other batteries OK.

Will replace this week.

Thanks for all the help. Will update when new one is installed.

Once I get that new one in - I can move on to "upgrade projects"
Blanko is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-23-2012, 04:47 PM   #42
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 2004 Precedent with new batteries going slow

ok thats a start i think we told ya early on in this thread it sounded like a battery issue.......................keep us updated.....................
shadowman is offline   Reply With Quote
Unread 01-30-2012, 10:32 PM   #43
Getting Wild
Club Car
 
Join Date: Dec 2011
Posts: 76
Smile Re: 2004 Precedent with new batteries going slow

Swapped in new battery to #4. Played 27 holes and charge on each battery still mid 12vs. No battery light at all.

Operation is now perfect. Thanks for all the help. Its amazing how a bad battery can look good.

The key diagnosis was measuring each battery at full charge then measuring each battery every 3 holes. The bad one drained quickly and was obvious through the readings.


Now let the upgrades begin................
Blanko is offline   Reply With Quote
Unread 01-31-2012, 07:26 AM   #44
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: 2004 Precedent with new batteries going slow

Quote:
Originally Posted by Blanko View Post
Swapped in new battery to #4. Played 27 holes and charge on each battery still mid 12vs. No battery light at all.

Operation is now perfect. Thanks for all the help. Its amazing how a bad battery can look good.

The key diagnosis was measuring each battery at full charge then measuring each battery every 3 holes. The bad one drained quickly and was obvious through the readings.


Now let the upgrades begin................
erict is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2004 Precedent Gas Club Car
2004 Precedent? Electric Club Car
2004 jerky clutch slip feel at slow accel. now no go. Electric EZGO
2004 DS 36V Slow uphill Electric Club Car
2004 Club Car is slow Electric Club Car


All times are GMT -5. The time now is 07:47 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.