lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-03-2012, 01:42 PM   #1
Getting Wild
Club Car
 
Join Date: Dec 2011
Posts: 76
Default 2004 Precedent with new batteries going slow

I have 2004 Precedent. Last summer local CC dealer/service replaced motor as last one burnt out. Since replacing it I couldnt get more than 16 holes (previously getting 2+ rounds). The local CC said I needed new batteries. I did that and got 18 holes+. However slowly but surely i have gotten less holes in and the car goes very slow up hill particularly on the 2nd 9. The battery light comes on from the 5th or 6th hole. I find if I unplug the charger and plug it back in (so it kicks on again) on the morning I am playing - it improves the situation that I can get 18 holes. But its still slow on hills. Batteries are US XC12V. Any help greatly appreciated.
Blanko is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-03-2012, 05:47 PM   #2
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: 2004 Precedent with new batteries going slow

Test all batteries 12 hours after charging for voltage and SG readings and post here . . . "new" batteries do not necessarily mean "good" batteries . . .
Stevegrmich is offline   Reply With Quote
Unread 01-04-2012, 05:07 PM   #3
Getting Wild
Club Car
 
Join Date: Dec 2011
Posts: 76
Default Re: 2004 Precedent with new batteries going slow

Thanks for the input.
Battery readings:
Overall voltage: 51.3
Battery 1 12.83v 1.306SG
Battery 2 12.96v 1.299SG
Battery 3 12.57v 1.294SG (one cell was 1.266SG)
Battery 4 12.94v 1.303SG
All SG converted to 80oF
Blanko is offline   Reply With Quote
Unread 01-04-2012, 05:21 PM   #4
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 2004 Precedent with new batteries going slow

the reading on that one cell is an issue...........................
shadowman is offline   Reply With Quote
Unread 01-04-2012, 05:37 PM   #5
Getting Wild
Club Car
 
Join Date: Dec 2011
Posts: 76
Default Re: 2004 Precedent with new batteries going slow

Replace the battery?
Blanko is offline   Reply With Quote
Unread 01-04-2012, 07:27 PM   #6
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: 2004 Precedent with new batteries going slow

Quote:
Originally Posted by Blanko View Post
Replace the battery?
Pack only as good as weakest link . . .
Stevegrmich is offline   Reply With Quote
Unread 01-04-2012, 08:34 PM   #7
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 2004 Precedent with new batteries going slow

Quote:
Originally Posted by Stevegrmich View Post
Pack only as good as weakest link . . .



........................................8 )
shadowman is offline   Reply With Quote
Unread 01-04-2012, 08:36 PM   #8
Gone Wild
 
kgsc's Avatar
E-Z-GO
 
Join Date: Dec 2009
Location: Aiken, SC
Posts: 6,166
Default Re: 2004 Precedent with new batteries going slow

When they replaced motor, did they put in a new one or used ? You may have a motor issue if it was used..
kgsc is offline   Reply With Quote
Unread 01-05-2012, 03:45 PM   #9
Getting Wild
Club Car
 
Join Date: Dec 2011
Posts: 76
Default Re: 2004 Precedent with new batteries going slow

Used. I got a new battery and put it in - we will see what that does
Blanko is offline   Reply With Quote
Unread 01-05-2012, 05:36 PM   #10
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 2004 Precedent with new batteries going slow

Quote:
Originally Posted by Blanko View Post
Used. I got a new battery and put it in - we will see what that does


..............thats a start.............................
shadowman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2004 Precedent Gas Club Car
2004 Precedent? Electric Club Car
2004 jerky clutch slip feel at slow accel. now no go. Electric EZGO
2004 DS 36V Slow uphill Electric Club Car
2004 Club Car is slow Electric Club Car


All times are GMT -5. The time now is 01:04 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.