lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-09-2012, 09:18 PM   #1
Not Yet Wild
 
Join Date: Jan 2012
Posts: 5
Default my first cart charging issues

first time on forum, just bought a 48v 04 club car
even when charged the cart is slow up a slight hill and charge only lasts 2 hours of riding. I has told (?) battaries are new..... when I connect to cart the charger goes to 12 and drops to 6-7 within a few hours. Any thoughts?
bullpup is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-10-2012, 06:47 AM   #2
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: my first cart charging issues

Quote:
Originally Posted by bullpup View Post
first time on forum, just bought a 48v 04 club car
even when charged the cart is slow up a slight hill and charge only lasts 2 hours of riding. I has told (?) battaries are new..... when I connect to cart the charger goes to 12 and drops to 6-7 within a few hours. Any thoughts?
There is a date code printed on the neg side terminal battery post. Please post the code. Also, post the individual readings of each battery after charging and resting for 12 hours.
erict is offline   Reply With Quote
Unread 01-10-2012, 10:38 AM   #3
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: my first cart charging issues

depending on what you mean by new............new batteries need broken in they are only about 75% until the 1st 10 or 15 charge/discharge cycles than they will come up to full...............very important that they are bronken in right or you might not be happy................now if they are like 1 yr old ( new ) batteries and you don,t know the history of them like how they were treated you might want to have them tested....voltage, load tested S/G readings cause its not hard to ruin a set of batteries if they wern,t treated right....................it does sould as if you have a battery issue.......lastly its possible to have 1 bad battery ( defect ) and that will cause this also.................................
shadowman is offline   Reply With Quote
Unread 01-10-2012, 11:20 AM   #4
Gone Wild
 
simple man's Avatar
E-Z-GO
 
Join Date: Aug 2011
Location: Bunnell, Florida
Posts: 2,408
Default Re: my first cart charging issues

Quote:
Originally Posted by bullpup View Post
first time on forum, just bought a 48v 04 club car
even when charged the cart is slow up a slight hill and charge only lasts 2 hours of riding. I has told (?) battaries are new..... when I connect to cart the charger goes to 12 and drops to 6-7 within a few hours. Any thoughts?
Two things come to mind, in addition to the other posts. First check the level of the electrolyte in the batteries. Add only enough distilled water to cover over the plates. Let your charger run until it shuts itself off. This may be up to 16 hrs! After the charger has stopped, then finish filling the batteries to the indicator inside the fill hole. Take voltage readings on each battery after using the cart about 10 min or so. Post your readings and we'll go from there!
You will hear boiling sounds from the batteries after several hours. This is normal. They will also get warm. They should not get hot!
simple man is offline   Reply With Quote
Unread 01-10-2012, 11:46 AM   #5
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: my first cart charging issues

All good troubleshooting suggestions. I am just curious if the batteries are really new
erict is offline   Reply With Quote
Unread 01-10-2012, 11:50 AM   #6
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: my first cart charging issues

Quote:
Originally Posted by erict View Post
All good troubleshooting suggestions. I am just curious if the batteries are really new



..........yes how new is " new "....................................
shadowman is offline   Reply With Quote
Unread 01-10-2012, 02:36 PM   #7
Not Yet Wild
 
Join Date: Jan 2012
Posts: 5
Default Re: my first cart charging issues

thanks all for the feedback. The batteries are all Deka Promate. look like a car battery, no date stamp just like a car batt where you peel off the month and year (not done). All very clean and I filled the core with distilled water. I do not have a meter to test strength. I am fairly handy, but this is all new to me.
bullpup is offline   Reply With Quote
Unread 01-10-2012, 02:44 PM   #8
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: my first cart charging issues

Quote:
Originally Posted by bullpup View Post
thanks all for the feedback. The batteries are all Deka Promate. look like a car battery, no date stamp just like a car batt where you peel off the month and year (not done). All very clean and I filled the core with distilled water. I do not have a meter to test strength. I am fairly handy, but this is all new to me.
Are they even golf cart batteries? This could be your issue.
erict is offline   Reply With Quote
Unread 01-10-2012, 02:46 PM   #9
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: my first cart charging issues

The first thing you want to find out is if they are true golf cart batteries. If they aren't then that's a problem. So try and find out what type of batteries they are golf cart, deep cycle, try and find out..................
shadowman is offline   Reply With Quote
Unread 01-10-2012, 02:53 PM   #10
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: my first cart charging issues

Can you take a pic of one? Did you mean Deka Promaster? Also the battery product number.
erict is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Electric EZ Go-Cart Charging Issues Electric EZGO
Rxv charging issues Electric EZGO
Charging issues Electric Club Car
99 DS charging issues Electric Club Car


All times are GMT -5. The time now is 03:30 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.