lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-01-2008, 02:26 PM   #1
Not Yet Wild
 
Join Date: Jul 2008
Posts: 2
Question 96 Club car sputters and will not accelerate

I have a 1996 Electric Club Car that has been working great. Today, my dad gets in and when he put it in reverse , it jumped. Then once he starting going forward the car would just sputter, almost like the motor is slipping. Any ideas?
bsnydes is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-01-2008, 02:55 PM   #2
Not Yet Wild
 
Join Date: Jun 2008
Posts: 7
Default Re: 96 Club car sputters and will not accelerate

I have no idea as to what the problem is but this sounds almost exactly what my problem was and it was thought to be the motor and it was not , sounds eriely like a bad controller but a skilled tech can tell you quickly.
msutim is offline   Reply With Quote
Unread 07-01-2008, 03:49 PM   #3
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: 96 Club car sputters and will not accelerate

Welcome to the forum bsnydes........................

Usually, when the shuddering happens, it's either bad battery cable connections or 1 bad battery. Check all connections on top of the batteries and check the voltage of all batteries as well as use a Hydrometer. That will fix it most of the time.
rusty is offline   Reply With Quote
Unread 07-01-2008, 08:32 PM   #4
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: 96 Club car sputters and will not accelerate

Rusty said it, battery and battery connections are the most common culprit. Look for rough wires before spending any big bucks on checking it out.
phasetim is offline   Reply With Quote
Unread 07-21-2008, 12:18 AM   #5
Not Yet Wild
 
Join Date: Jul 2008
Posts: 2
Thumbs up Re: 96 Club car sputters and will not accelerate



It was a bad battery connection! Thanks to all.......
bsnydes is offline   Reply With Quote
Unread 07-21-2008, 12:20 AM   #6
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: 96 Club car sputters and will not accelerate

Glad we could help......... Thank You.
rusty is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes



All times are GMT -5. The time now is 11:47 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.