lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-03-2008, 03:35 PM   #1
Not Yet Wild
Club Car
 
Join Date: Jul 2008
Posts: 1
Cool Electric Club Car wont Go!!

Hello All

I have a 2004 48 volt Club Car with IQ I have owned it for 2 years I have had to replace the cable ends before when it quits running because they corrode off. THis time when it quit, if you push the accelerator pedal it tries to lurch forward then will not go, it does act like it wants to though. The reverse beeper works when put in reverse. I was wondering what voltages I should have at the motor to determine if I have a bad motor or a bad controller or what. Or if someone knows if I am headed down the wrong path. Any help is appreciated.

Thanks!
tee2green2003 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-03-2008, 06:41 PM   #2
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: Electric Club Car wont Go!!

Welcome to the forum tee2green2003......................

Headed down the wrong path........... Start checking the batteries. It sounds pretty typical of one bad battery or loose connections.

Get a volt meter and check each battery. Might even get a Hydrometer and test the batteries that way too. Usually any battery below 8 volts is a BAD battery if it has been charged recently. They should read about 8.5 volts on good batteries.

Let us know.
rusty is offline   Reply With Quote
Unread 07-03-2008, 06:49 PM   #3
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,913
Default Re: Electric Club Car wont Go!!

I agree, headed down the wrong path. Rusty is correct, sounds typical of a bad connection. If it worked before and nothing has been touched that makes it even more likely its a bad connection. (bad thing do "Just happen" though) I suggest giving each one of them a good tug....maybe even take them loose one at a time....clean them....and put them right back on.

I fixed one a few weeks back.....the only thing holding the cable on the terminal was electrical tape. Connection looked good....no corrosion...not anything. I tugged on the cable and it came loose, left the tape on the battery terminal.
roady89 is online now   Reply With Quote
Unread 07-03-2008, 10:04 PM   #4
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: Electric Club Car wont Go!!

If it makes one simple bump forward then quits; it is typical of a failed solenoid.

Test the solenoid for continuity when you are engaging it.
phasetim is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Electric Club Car wiring Electric Club Car
1995 club car wont move Electric Club Car
Electric Club Car Died - HELP Electric Club Car
club car wont go Electric Club Car


All times are GMT -5. The time now is 05:54 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.