lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-15-2012, 10:46 PM   #11
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,015
Default Re: Cart Problems: Speed Sensor & Motor Stall

Do what I said in post #4 and give me the numbers
TahoeDawgZ71 is online now   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-19-2012, 08:48 AM   #12
Not Yet Wild
 
Join Date: Apr 2011
Posts: 19
Default Re: Cart Problems: Speed Sensor & Motor Stall

Have not had a chance to get the computer back yet but i installed the plum quick bandit over the weekend and everything is working fine, no stalls, no reduced speed and it bumped me up to 24MPH, the only thing that i noticed is after i road for a hour or so the motor was hot to the touch, is this normail after a pretty good ride, thanks,dusty
dragster777 is offline   Reply With Quote
Unread 03-19-2012, 08:51 AM   #13
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: Cart Problems: Speed Sensor & Motor Stall

hmmm . . . your PQ hot to touch and in another thread, guy's PQ smoked . . what is happening here??
Stevegrmich is offline   Reply With Quote
Unread 03-19-2012, 01:42 PM   #14
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,015
Default Re: Cart Problems: Speed Sensor & Motor Stall

Quote:
Originally Posted by dragster777 View Post
Have not had a chance to get the computer back yet but i installed the plum quick bandit over the weekend and everything is working fine, no stalls, no reduced speed and it bumped me up to 24MPH, the only thing that i noticed is after i road for a hour or so the motor was hot to the touch, is this normail after a pretty good ride, thanks,dusty
Good. There's a small chance that your MOTOR STALL code was coming from a bad motor. It's usually voltage, but not always. As for the heat issue I wouldn't be too concerned with it. My PQ motor is more aggressive than the Bandit so I realize I'm not comparing apples to apples but mine gets pretty dang hot. I've never had a problem with it at all though.
TahoeDawgZ71 is online now   Reply With Quote
Unread 03-19-2012, 04:10 PM   #15
Not Yet Wild
 
Join Date: Apr 2011
Posts: 19
Default Re: Cart Problems: Speed Sensor & Motor Stall

Thanks for all the help, i talk with rick at plum quick again and he said that the motor would get hot after a long ride but as long as i could touch it for 3 to 4 seconds that he would not worry about it, the biggest thank not to do is stall the motor. Thanks for the post and if there is any other small upgrades that i could do to get a little more speed and touque let me know, fixen to put a back seat kit and light on it. Thanks,
dragster777 is offline   Reply With Quote
Unread 03-23-2012, 06:50 AM   #16
Mr. Helper
 
ForBruce's Avatar
Club Car
 
Join Date: May 2009
Location: NY Catskills & South carolina
Posts: 436
Default Re: Cart Problems: Speed Sensor & Motor Stall

Quote:
Originally Posted by Stevegrmich View Post
hmmm . . . your PQ hot to touch and in another thread, guy's PQ smoked . . what is happening here??
not sure about DC motors but Ac motors run about 70 degrees over ambient temperature normally .
In other words if it's 80 degrees outside the motor runs at 150 degrees....which is hot to the touch
ForBruce is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
MCOR? Speed Sensor? Controller? Cart Runs at half speed. Advice, please. Electric Club Car
08 precedent electric speed sensor problem. Cart starts at proper speed then slows . Electric Club Car
precedent motor speed sensor Electric Club Car
D&D motor speed sensor. Electric Club Car
97 regen motor speed sensor Electric Club Car


All times are GMT -5. The time now is 03:47 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.