lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars

Post New Thread  Reply
Thread Tools Display Modes
Unread 07-08-2008, 09:47 AM   #1
Not Yet Wild
Join Date: Jul 2008
Posts: 1
Default '99 48V just quit after no previous problem

My cart quit Sunday night after a day of driving all over the neighborhood. Prior to it quitting I had not experienced any type of problem: it ran fine, held a charge, etc. We stopped to watch some local fireworks, and when we got in it to leave, it wouldn't move at all. The lights still worked fine, but when I lifted the seat it seemed like I could smell a faint odor of burnt electrical. I ended up having to push it home (in neutral). Yesterday I noticed that the forward/reverse lever seems not to operate as smoothly as before. I checked all the batteries and they are at 8.5+ volts each, 53+ total. Fooling with the lever at one point made the car leap forward about 10 feet then quit. It seems like when I let it sit for a while and then I step on the gas, it wants to go for a second, but then - nothing. Could it be the F/R control? Microswitches? The cart was purchased in 2002 as a reconditioned model. It had new batteries installed at that time, but they've not been replaced since. I've maintained them regularly, and charge after every use. We were carrying a full load all day Sunday (4 adults), which we normally don't. Any help would be greatly appreciated!
Hadmonkey is offline   Reply With Quote
Alt Today

Golf car forum Sponsored Links

This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
Unread 07-08-2008, 10:30 AM   #2
Golf Cart Photographer
rusty's Avatar
Club Car
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: '99 48V just quit after no previous problem

Welcome to the forum Hadmonkey.............................

If you worked the F/R handle and it moved, then you most likely have bad contacts. Also you said it did not work as smoothly. - Repair that assembly. You'll probably find the contacts burned up.
rusty is offline   Reply With Quote
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car

Thread Tools
Display Modes

Similar Threads
Thread Forum
Just quit... Electric EZGO
governer quit! Gas Club Car
EZGO quit Electric EZGO
Charger won't quit Electric Club Car

All times are GMT -5. The time now is 01:29 AM.

Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.