lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-22-2012, 08:34 PM   #1
Not Yet Wild
 
Join Date: Apr 2012
Posts: 47
Default CC DS New motor/controller problem

Hey guys, Im new the forum here and golf carts in general…. I bought a 2005 club car ds…. I Upgraded the motor controller solenoid and wires all from d&d ….. Its the 11.2 hp torque motor and 500 amp programable controller 4 ga wires….. I also put Brand new interstate batteries in the car (6) 8 v. The cart works and goes forward and reverse but has no power!!! So i got the old volt meter out…… heres what i got… i put the black on the b- terminal on controller( goes to first neg battery). I touched red to the + solenoid and got 49.2v then touched the other side of solenoid(where resistor connects) and got 47.9v. Then i jacked up the back of the cart and tested what the controller was reading on the b+ and m- terminals to motor… With the gas all the way to the floor the voltage was only around 28 volts?!?!?!?!?!?!? is my brand new alltrax controller messed up? The guy from d&d was supposed to set it up from the factory… not sure how just said he would set it up for about 16 mph ( the cart is more for torque and hunting) Please help me figure this out and can't wait to feel what this baby has in her!! thanks
a3fan11atick is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-22-2012, 08:36 PM   #2
Not Yet Wild
 
Join Date: Apr 2012
Posts: 47
Default Re: CC DS New motor/controller problem

Hey guys, Im new the forum here and golf carts in general…. I bought a 2005 club car ds…. I Upgraded the motor controller solenoid and wires all from d&d ….. Its the 11.2 hp torque motor and 500 amp programable controller 4 ga wires….. I also put Brand new interstate batteries in the car (6) 8 v. The cart works and goes forward and reverse but has no power!!! So i got the old volt meter out…… heres what i got… i put the black on the b- terminal on controller( goes to first neg battery). I touched red to the + solenoid and got 49.2v then touched the other side of solenoid(where resistor connects) and got 47.9v. Then i jacked up the back of the cart and tested what the controller was reading on the b+ and m- terminals to motor… With the gas all the way to the floor the voltage was only around 28 volts?!?!?!?!?!?!? is my brand new alltrax controller messed up? The guy from d&d was supposed to set it up from the factory… not sure how just said he would set it up for about 16 mph ( the cart is more for torque and hunting) Please help me figure this out and can't wait to feel what this baby has in her!! thanks
a3fan11atick is offline   Reply With Quote
Reply

Tags
motor controller d&d
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
controller, motor problem Electric EZGO
Motor controller and Motor match? Electric Club Car
New installed controller and motor.. stop and go problem Electric EZGO
a DC motor controller ( electronic speed controller) Golf Carts and Parts
99 controller problem Electric Club Car


All times are GMT -5. The time now is 09:54 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.