lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-11-2008, 09:27 AM   #1
Not Yet Wild
 
Join Date: Jun 2008
Posts: 16
Default 2 Controllers gone, maybe battery

I posted here a month ago, about a problem with a cart, when you press the pedal, you hear clicking, and that was it. After verifying all connections, and finally replacing controller, it worked again for a ride around the block.

The second controller went 4 minutes after the first controller. I took apart the controller, and found that both units had blown the 4 FS transistors.

after talking to some people here were my options.

1. Motor was bad. I have the supplement manual for the vehicle, and verified motor was 1.9 ohms across F1,F2, and no short to chassis or motor body.
2. Light kit cabling was bad, I removed the whole light kit, no change.



I think I am getting close, but I do not believe the answer, looking for help.

I discconect all battery terminals.

I measure DC volts from the positive terminal to the chassis, while the battery is sitting in battery base. 6 of the 8 batteries, measure nothing, 1 measures 1.1 volts, and 1 measures 3 volts. When I chain them together, I have a total of 8 volts from positive to chassis, without anything connected to the body.

Here is the strange part, I have been told that if I have a black cased battery, it could have been made of recycled plastic, and that the carbon content can vary, to the point it will conduct. I actually was getting 8 volts rfom the battery case to postive when I started, and after cleaning all of the crud of the battery, I am down to 3 volts.

Has anyone ever heard of this ?.

Barry
BBourdage is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-11-2008, 09:31 AM   #2
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,913
Default Re: 2 Controllers gone, maybe battery

Do you have larger than stock tires?
roady89 is offline   Reply With Quote
Unread 07-11-2008, 09:46 AM   #3
Not Yet Wild
 
Join Date: Jun 2008
Posts: 16
Default Re: 2 Controllers gone, maybe battery

Yes, 22's, I have a couple of other carts with pretty much the same configureation, and this is the only one that blows the controller.

Does the short across the battery case make sense ?
BBourdage is offline   Reply With Quote
Unread 07-11-2008, 09:57 AM   #4
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,913
Default Re: 2 Controllers gone, maybe battery

How many amps on the controller? Is it a stock 235 amp?

Also...the transistors that are blown do they have a direct path from the A2 terminal?
roady89 is offline   Reply With Quote
Unread 07-11-2008, 10:02 AM   #5
Not Yet Wild
 
Join Date: Jun 2008
Posts: 16
Default Re: 2 Controllers gone, maybe battery

I have the stock 1510-5201, curtis controller (2003 IQ).

No direct patch, only through the stock interface on the curits.
BBourdage is offline   Reply With Quote
Unread 07-11-2008, 10:12 AM   #6
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,913
Default Re: 2 Controllers gone, maybe battery

Ok, didn't realize it's on IQ but thats ok. Does it blow controllers on hills or under load? I belive thats a 235 amp controller.
roady89 is offline   Reply With Quote
Unread 07-11-2008, 10:14 AM   #7
Not Yet Wild
 
Join Date: Jun 2008
Posts: 16
Default Re: 2 Controllers gone, maybe battery

No load, just sitting. Remember, it has done this to 2 controllers already, I did not want to put a third one on it, until I had this voltage problem solved.

What do you think about the voltage ?
BBourdage is offline   Reply With Quote
Unread 07-11-2008, 10:16 AM   #8
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,913
Default Re: 2 Controllers gone, maybe battery

Never seen it happen or heard of that. Todays batteries "should" not conduct power through the case. Only time I have seen batteries conduct is if there is water and/or battery acid, dirt etc on the batteries. Switch batteries with another cart and find out.
roady89 is offline   Reply With Quote
Unread 07-11-2008, 10:19 AM   #9
Not Yet Wild
 
Join Date: Jun 2008
Posts: 16
Default Re: 2 Controllers gone, maybe battery

We did switch batteries, and had no issue, I am just afraid to burn another controller on it.

Thanks for your help
BBourdage is offline   Reply With Quote
Unread 07-11-2008, 09:33 PM   #10
Getting Wild
 
on18's's Avatar
Club Car
 
Join Date: Jul 2008
Location: odessa.fl
Posts: 99
Default Re: 2 Controllers gone, maybe battery

this my sound stupid but i seen some thing like this on a ezgo the guy put in a stereo and head lights and grounded them to the frame of the cart and not to batteries it burnt up controllers and 2 radios before he brought it to the shop and i traced burnt wires to the frame it was feeding back thew controller
on18's is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Kelly Controllers Electric Club Car
Controllers Wanted Golf Carts and Parts
Controllers Help!!!!! Electric Yamaha
EZGO Controllers Electric EZGO
Controllers Electric Club Car


All times are GMT -5. The time now is 12:03 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.