lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-12-2012, 07:28 AM   #11
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: electrical probs

Quote:
Originally Posted by catdaddyno1 View Post
Talked to dealer about the 48v to frame they said the frames have just have a charge.


Stevegrmich is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-13-2012, 05:46 AM   #12
Not Yet Wild
 
Join Date: Apr 2012
Posts: 5
Default Re: electrical probs

we went out and tested one of the club cars that he had and it had voltage when the neg lead of the voltmeter is on the neg of the battery and pos lead on the frame. I didn't think that was right either but I'm no expert, not saying he was either. I have been shocked by it but I was grounded to the battery

it runs fine but I'll look to see if the frame is rubbing a wire or something. One more thing about the voltage on the frame. It would change depending on which battery neg post I put the neg lead on. I would get 4v if I used the first battery in the series and on the second it would be like 11v, on the next 20v and so on until the last battery and it would be 48v. Let me remind you that when I get these readings my pos and neg cables are not connected to the batteries.
catdaddyno1 is offline   Reply With Quote
Unread 05-13-2012, 04:02 PM   #13
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: electrical probs

what does the battery tray look like? it could be the batteries just sitting there iof theres a nasty build up on tray................................
shadowman is offline   Reply With Quote
Unread 05-13-2012, 05:37 PM   #14
Not Yet Wild
 
Join Date: Apr 2012
Posts: 5
Default Re: electrical probs

yeah i hosed off the buildup around the bottom of the batteries didn't test the frame again but gonna pull the batteries out and clean it off good should i paint it or just put down rubber matt to set them on?
catdaddyno1 is offline   Reply With Quote
Unread 05-13-2012, 05:41 PM   #15
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: electrical probs

if you can get that rubberized paint thats the way to go..........................
shadowman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
'84 Electric ezgo electrical probs goes by itself and jumps gears Electric EZGO
OBC ver. 2.05 Any probs with this version? Electric Club Car
Re: Yamaha G8 Electrical issue solved....speed probs. Electric Yamaha
New light kit probs, 48v CC Electric Club Car
G2 fuel probs Gas Yamaha


All times are GMT -5. The time now is 09:15 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.