lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars

Post New Thread  Reply
Thread Tools Display Modes
Unread 05-09-2012, 12:37 PM   #1
Not Yet Wild
Join Date: May 2012
Posts: 1
Default 98 club car problem

Hello everyone,
Im having trouble getting my 98 club car to run. I dont usually post on forums asking for help unless i feel i have browsed around enough to make it worth your time. So thanks in advance for anyone who decides to help. I appreciate it alot.

This is a 98 club car 48v which looks like the previous owner had someone do a upgrade to the 36 volt motor.

Problem: Cart will not move.
The cart quit on me after backing out of someones driveway.
I have tested the voltage on the pack and it reads 49.5
I have replaced the solenoid along with the diode and resistor. But I cannot even get the solenoid to click. It works fine if I jump the two large posts on the solenoid.
The cart also charges just fine.
I'm in the process of resetting the OBC while typing this post.

Sorry if i forgot to post some info.

Editing to say; The resistor on the solenoid also seems to get very hot when pushing on the accelerator pedal.

ok i figured it out its the yellow wire that comes out of the obc that has something wrong with it. when i jump from that post to ground on #6 battery it runs fine. Does that mean i need a new obc?
csvin is offline   Reply With Quote
Alt Today

Golf car forum Sponsored Links

This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
Unread 05-09-2012, 09:06 PM   #2
The Last Moja Morani
shadowman's Avatar
Club Car
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 98 club car problem

i would check the microswitch that activates the solenoid and the wiring for it......if it runs when you jump it it has to be in activation circuit.................
shadowman is offline   Reply With Quote
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car

Thread Tools
Display Modes

Similar Threads
Thread Forum
club car problem Gas Club Car
92 Club car run problem Gas Club Car
Club Car problem Electric Club Car
I'm new here and have a Club Car problem. Electric Club Car
98 Club Car problem Electric Club Car

All times are GMT -5. The time now is 06:10 PM.

Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.