lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-14-2012, 10:58 PM   #1
Not Yet Wild
Club Car
 
Join Date: May 2012
Location: The Villages Fl & Pgh. Pa
Posts: 4
Default No lights,signals,horn

I parked my Club Car 2hours later no lights. Runs fine! 20 amp fuse OK, The light switch is OK, wiring looks fine,bulbs checked OK. I found two round relays behind the dash that I'm going to replace. My question is there anything I'm overlooking & is this a common problem?
Thanks
Larry
91jaguar is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-15-2012, 07:09 AM   #2
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: No lights,signals,horn

Need more info . . year, model, factory lights, etc . . . depending on your setup, it could be a voltage reducer issue also . . .
Stevegrmich is offline   Reply With Quote
Unread 05-15-2012, 09:57 AM   #3
Not Yet Wild
Club Car
 
Join Date: May 2012
Location: The Villages Fl & Pgh. Pa
Posts: 4
Default Re: No lights,signals,horn

Thanks for your reply Steve. I got the cart about 6 months ago. From some paper work I found along with the serial # I think it's a 06 or 07 & has factory or dealer installed lights. I'll do more homework today.

Larry
91jaguar is offline   Reply With Quote
Unread 05-15-2012, 04:58 PM   #4
Gone Wild
 
89GatorClub's Avatar
Club Car
 
Join Date: Mar 2012
Location: Palatka, Fl
Posts: 799
Default Re: No lights,signals,horn

I would check to make sure they are properly grounded
89GatorClub is offline   Reply With Quote
Unread 05-16-2012, 09:02 PM   #5
Not Yet Wild
Club Car
 
Join Date: May 2012
Location: The Villages Fl & Pgh. Pa
Posts: 4
Default Re: No lights,signals,horn

You were right, bad ground at one of those "one into two" white conectors that goes to the ground on one of the batteries. Also this cart doesn't have a voltage. Thanks again.

Larry
91jaguar is offline   Reply With Quote
Unread 05-16-2012, 10:49 PM   #6
Gone Wild
 
89GatorClub's Avatar
Club Car
 
Join Date: Mar 2012
Location: Palatka, Fl
Posts: 799
Default Re: No lights,signals,horn

w00t
89GatorClub is offline   Reply With Quote
Unread 05-16-2012, 11:20 PM   #7
Not Yet Wild
Club Car
 
Join Date: May 2012
Location: The Villages Fl & Pgh. Pa
Posts: 4
Default Re: No lights,signals,horn

Forgot to finish the last sentence, doesn't have a voltage " reducer".
Larry
91jaguar is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Electric won't move (lights, signals work though) Electric Yamaha
Horn, signals, Lights DON"T WORK HELP Electric golf carts
brake lights, turn signals, horn? Gas Club Car
Hooking up turn signals with brake lights without a kit Gas EZGO
Adding turn signals to '07 Precedent w/lights Electric Club Car


All times are GMT -5. The time now is 11:40 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.