lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-21-2012, 05:27 PM   #1
Getting Wild
 
Tbinkley3's Avatar
Club Car
 
Join Date: Jun 2010
Location: Southeast
Posts: 139
Default Got another cart

It's been a while since I have been on here and just bought another cart. Club Car 2004 DS. Serial # AA0409. I'm going to need some feedback on a couple of things, but I'll start with an easy one.
Question: Any suggestions or tricks of the trade on removing water from the batteries. Whoever added water prior to my purchasing it literally filled the battery up...almost to the brim. I heard boiling during charging, checked and liquid was leaking from the fill holes on 3 of the batteries so I interupted the charging process and have been using a Battery tester to remove the water but it's getting everywhere and making one hell of a mess. Any suggestions?
Tbinkley3 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-21-2012, 10:28 PM   #2
STEALTH 4X4
 
sunoco's Avatar
Club Car
 
Join Date: Sep 2011
Location: GA
Posts: 2,017
Default Re: Got another cart

Turkey baster? lol

What about a small siphon with a pump bulb on it?
sunoco is offline   Reply With Quote
Unread 05-22-2012, 07:46 AM   #3
Getting Wild
 
Tbinkley3's Avatar
Club Car
 
Join Date: Jun 2010
Location: Southeast
Posts: 139
Default Re: Got another cart

Thanks sunoco...that occurred to me last night after a few beers. Raided the utensil drawer and viola
Tbinkley3 is offline   Reply With Quote
Unread 05-22-2012, 02:20 PM   #4
Getting Wild
 
Tbinkley3's Avatar
Club Car
 
Join Date: Jun 2010
Location: Southeast
Posts: 139
Default Re: Got another cart

On to the next issue. I've included pictures. This cart has an FS Motor Controller (see pictures) the label has been torn off so I can't come up with a model number. If anyone recognizes it and thinks they may know the model # I would appreciate that info.
The issue that I am dealing with is the 3 adjustment holes on top. It's a ton of trial and error trying to get this thing adjusted to where I can handle the thing. I have found some info on the manufacturers web site but the info is very limited. I have identified what each hole/adjustment is for. I get on this cart and depress the throttle and it litterally jumps into action. It's very fast and the take off is extreme even for me. I guess I'm soliciting any feedback or thoughts from those that are familiar with this Motor Controller.
Attached Images
File Type: jpg Controller FS pic 1.JPG (359.8 KB, 0 views)
File Type: jpg Controller Pic 2.JPG (382.7 KB, 0 views)
File Type: jpg Controller Pic 3.JPG (407.1 KB, 0 views)
Tbinkley3 is offline   Reply With Quote
Unread 05-23-2012, 12:14 PM   #5
Not Yet Wild
Club Car
 
Join Date: May 2012
Location: Wisconsin
Posts: 41
Default Re: Got another cart

You might possibly have a bad MCOR. I had the same problem. When I slowly stepped on the pedal it would give you a hell of a jerk. Replace the MCOR and works great. Just a tought, I am no expert by any means.
Jazz24 is offline   Reply With Quote
Unread 05-23-2012, 01:34 PM   #6
Getting Wild
 
Tbinkley3's Avatar
Club Car
 
Join Date: Jun 2010
Location: Southeast
Posts: 139
Default Re: Got another cart

Thanks jazz...I hope that is not the case. We'll see. I really to identify the model # so that I can research better.
Tbinkley3 is offline   Reply With Quote
Unread 05-23-2012, 02:19 PM   #7
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,055
Default Re: Got another cart

You probably have mismatch between your throttle output and the controller input. They can not communicate. There is no adjustment for this in this type of control. If this is the case you simply have the wrong unit.

Turn all of the adjustment screws all the way down (left) and if the carts still starts hard, it's very likely you are barking up the wrong tree.
scottyb is offline   Reply With Quote
Unread 05-23-2012, 02:57 PM   #8
Getting Wild
 
Tbinkley3's Avatar
Club Car
 
Join Date: Jun 2010
Location: Southeast
Posts: 139
Default Re: Got another cart

Thanks Scottyb...that made a huge difference. I really appreciate you taking the time.
Tbinkley3 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes



All times are GMT -5. The time now is 05:11 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.