lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-24-2012, 09:34 PM   #1
Not Yet Wild
 
Join Date: May 2012
Posts: 2
Default 1997 club car runs half speed

I have a 1997 electric club car. When I press the accelerator sometimes it does not get any juice. When I press it again it begins to run but only at a fraction of the speed and will not make it up even a gentle hill. Does anybody have an idea what it could be and how I could troubleshoot it?

Thanks,
Craig
bertola is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-25-2012, 09:10 AM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 1997 club car runs half speed

you need to start with basics 1st...............did this problem just occur? or has it been doing it? test voltage of each battery and load test each one.....take SG readings of each cell with a hydrometer, keep in mind it only takes one battery to mess things up...........also check and clean/tighten all battery cables, if your unsure about battery readings post #,s and don,t just assume they are good test them......it could also be a solenoid going bad even though its rare they go bad in that way on occasion they do but start with batteries/cables....................................
shadowman is offline   Reply With Quote
Unread 05-27-2012, 11:36 AM   #3
Not Yet Wild
 
Join Date: May 2012
Posts: 2
Default Re: 1997 club car runs half speed

Thanks for the info. I checked the batteries and indeed one of them was bad and causing the problem. Issue is resolved.

Craig
bertola is offline   Reply With Quote
Unread 05-30-2012, 10:13 AM   #4
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 1997 club car runs half speed

Quote:
Originally Posted by bertola View Post
Thanks for the info. I checked the batteries and indeed one of them was bad and causing the problem. Issue is resolved.

Craig


.......................................
shadowman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
MCOR? Speed Sensor? Controller? Cart Runs at half speed. Advice, please. Electric Club Car
96 Club Car runs at half power Electric Club Car
club car goes only half speed Electric Club Car
Club Car 1997 One Speed Electric Club Car
2002 CC DS runs at half speed Electric Club Car


All times are GMT -5. The time now is 09:35 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.