lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-06-2012, 09:53 AM   #21
Not Yet Wild
 
Join Date: Jun 2012
Posts: 34
Default Re: DS IQ will not run, NEW batteries just installed

Ordered from site sponsor. Thanks for all the help
omalley is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-07-2012, 03:17 PM   #22
Not Yet Wild
 
Join Date: Jun 2012
Posts: 34
Default Re: DS IQ will not run, NEW batteries just installed

Well, decided to upgrade to the 400 amp version since I'm not planning on changing out the motor and ordered the alltrax DCX400IQ. Got it installed but there isn't a provision to hook up the IQ wire controls from the F-R switch. Decided to try it anyway but am still having the same problems, buzzer sounds for about 5 seconds, stops for about 5 seconds and no go. When I put the FR switch to F, the battery light illuminates brightly yet the charger cycled completely last night. My accessories (radio and lights) work just fine. Any suggestions? The LED on the Alltrax is showing that everything is hooked up right.
omalley is offline   Reply With Quote
Unread 06-07-2012, 04:56 PM   #23
Not Yet Wild
 
Join Date: Jun 2012
Posts: 34
Default Re: DS IQ will not run, NEW batteries just installed

Since verified that the Alltrax is hooked up correctly yet the solenoid is not getting it's switching current. Tried jumping the big wires together and still no go. A weird issue that I am experiencing is that when I switch the tow/go switch from tow to go, even with the cart off, the buzzer will buzz constantly. Now I am going to look for the MCOR test procedure. Hope it's somewhere on this site
omalley is offline   Reply With Quote
Unread 06-07-2012, 05:37 PM   #24
Not Yet Wild
 
Join Date: Jun 2012
Posts: 34
Default Re: DS IQ will not run, NEW batteries just installed

I'm so confused now, I'm about afraid to do much more for fear of frying stuff! If I read this correctly, I could jumper the 2 wire plug going into the MCOR to eliminate the MCOR micro switch. Nothing happened. I also read that if I ran a jumper from the big yellow wire to the battery negative, that that would eliminate the OBC's job of grounding the circuit. Tried that and got a nice spark so I yanked it off. Does anyone have any idea's? Right now, I am leaning toward the OBC being bad yet it charges the batteries just fine. HELP!!
omalley is offline   Reply With Quote
Unread 06-07-2012, 06:05 PM   #25
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: DS IQ will not run, NEW batteries just installed

if you can wait for david let him read this.................................
shadowman is offline   Reply With Quote
Unread 06-07-2012, 06:16 PM   #26
Not Yet Wild
 
Join Date: Jun 2012
Posts: 34
Default Re: DS IQ will not run, NEW batteries just installed

I finally found some detailed instructions on checking the MCOR. Printing them off and heading home for a very stiff drink and get back on it tomorrow. Tried attempting them earlier without the diagrams and the voltages were WAY out of wack. I'm sure its the operator and not the buggy at the moment.

Definitely willing to wait for David to chime in.

THanks !!
omalley is offline   Reply With Quote
Unread 06-07-2012, 06:40 PM   #27
Not Yet Wild
Club Car
 
Join Date: Aug 2009
Location: Roseville, MI
Posts: 62
Default Re: DS IQ will not run, NEW batteries just installed

I had this same problem on a 48 volt cc I had just put new batteries in. I wired batteries wrong with 36 volts, had the back up buzzer but no go
Dav1774 is offline   Reply With Quote
Unread 06-07-2012, 07:28 PM   #28
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,977
Default Re: DS IQ will not run, NEW batteries just installed

Wow glad I saw this. The MCOR has absolutely nothing to do with the reverse buzzer. If your buzzer is turning on immediately when you put the car in "RUN" you've either got the buzzer hooked up wrong or you've got a controller issue. Was it doing this before the big spark from the OBC bypass attempt? That test procedure only applies to a series car. Basically what you did was create a direct 48V short from the solenoid to the B- battery. That's why it sparked. I hope and pray that didn't damage the controller, because it can definitely do that. I doubt very seriously that the OBC is your issue. I honestly don't see how it could be. The OBC is responsible for charging the car and powering up the controller. It's obviously powering up your controller because if it wasn't, the reverse buzzer wouldn't work at all. It's not like an old school cart with microswitches engaging the buzzer on a standalone circuit. On an IQ, the buzzer is controlled by the controller itself. I go back to my earlier point, it's possible that a bad F&R switch can cause this, however you confirmed that this still happens even with the switch unplugged. I feel very confident that there's a wiring issue somewhere or the controller is bad. I realize you've tried this on two different controllers, but I've seen crazier things happen. However, considering the odds of two controllers in a row doing the same thing, I'd say there's a wiring issue somewhere.... Take your dash panel off and look at your buzzer. It should have a red wire on the passenger side post and an orange wire on the driver's side post. I'm somewhat unclear of what you're saying in your above post about the All-Trax controller not having a place to hook up the F&R controls from the F&R switch. All of these controls are integrated into the 16 pin connector. If you're talking about the 4 pin connector, just leave it unplugged. That's the communication port for the Curtis controller.
TahoeDawgZ71 is offline   Reply With Quote
Unread 06-07-2012, 07:32 PM   #29
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,977
Default Re: DS IQ will not run, NEW batteries just installed

On another note, what's the current battery voltage? What kind of batteries did you install?
TahoeDawgZ71 is offline   Reply With Quote
Unread 06-07-2012, 08:48 PM   #30
Not Yet Wild
 
Join Date: Jun 2012
Posts: 34
Default Re: DS IQ will not run, NEW batteries just installed

Batteries measure 50.something volts, so I'm pretty sure they're hooked up correctly. As for type, 6, 8 volt batteries can't recall brand other than they're premium. Buzzer did same thing with both controllers and it appears to be correct. Will verify tomorrow when. I'm back in front of it. LED still glows solid so I'm pretty sure it's ok. I hope. Where would you recommend I start trouble shooting the wiring?
omalley is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Installed new batteries with Cart in Run Mode...not Tow/Maintenance Electric EZGO
Batteries Installed Backward Electric EZGO
Just Installed New Batteries - What do I need to do Next? Electric EZGO
Installed trojans last night Batteries not charging..... Or maybe they are?.... Electric Club Car
Installed new batteries Electric Club Car


All times are GMT -5. The time now is 10:55 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.