lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-07-2012, 08:53 PM   #31
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,960
Default Re: DS IQ will not run, NEW batteries just installed

Quote:
Originally Posted by omalley View Post
Batteries measure 50.something volts, so I'm pretty sure they're hooked up correctly. As for type, 6, 8 volt batteries can't recall brand other than they're premium. Buzzer did same thing with both controllers and it appears to be correct. Will verify tomorrow when. I'm back in front of it. LED still glows solid so I'm pretty sure it's ok. I hope. Where would you recommend I start trouble shooting the wiring?
check behind the dash to make sure the buzzer is hooked up like i described. You owe it to yourself to call a dealer and order an Illustrated Parts List for your vehicle. It shows detailed and accurate wiring diagrams that are very easy to read.
TahoeDawgZ71 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-07-2012, 09:57 PM   #32
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,960
Default Re: DS IQ will not run, NEW batteries just installed

Quote:
Originally Posted by omalley View Post
Well, decided to upgrade to the 400 amp version since I'm not planning on changing out the motor and ordered the alltrax DCX400IQ. Got it installed but there isn't a provision to hook up the IQ wire controls from the F-R switch. Decided to try it anyway but am still having the same problems, buzzer sounds for about 5 seconds, stops for about 5 seconds and no go. When I put the FR switch to F, the battery light illuminates brightly yet the charger cycled completely last night. My accessories (radio and lights) work just fine. Any suggestions? The LED on the Alltrax is showing that everything is hooked up right.
After reading this again I would DEFINITELY check your wires. It sounds like the brown wire from the obc that is supposed to go to the amber light is actually hooked to the buzzer. This explains the 5 seconds on 5 seconds off pattern. The fact that the orange light responds to the f&r switch it sounds exactly like the reverse buzzer wire is hooked to the light. Check this ASAP to confirm. Please feel free to send a phone pic to me at 706-836-7210

PS. Are we absolutely positive this is an IQ and not a Regen2? What's the serial number?
TahoeDawgZ71 is offline   Reply With Quote
Unread 06-08-2012, 07:41 AM   #33
Not Yet Wild
 
Join Date: Jun 2012
Posts: 34
Default Re: DS IQ will not run, NEW batteries just installed

The serial number has been painted over but everything I've found points to this being an IQ. Will reverify wiring later this morning after I've handled some real work versus screwing off on is golfcart
omalley is offline   Reply With Quote
Unread 06-08-2012, 07:50 AM   #34
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: DS IQ will not run, NEW batteries just installed

Quote:
Originally Posted by omalley View Post
The serial number has been painted over but everything I've found points to this being an IQ. Will reverify wiring later this morning after I've handled some real work versus screwing off on is golfcart
Look behind the keyswitch dashplate . . there may/should be another serial number tag there on right side . . .
Stevegrmich is offline   Reply With Quote
Unread 06-08-2012, 08:56 AM   #35
Not Yet Wild
 
Join Date: Jun 2012
Posts: 34
Default Re: DS IQ will not run, NEW batteries just installed

Quote:
Originally Posted by TahoeDawgZ71 View Post
After reading this again I would DEFINITELY check your wires. It sounds like the brown wire from the obc that is supposed to go to the amber light is actually hooked to the buzzer. This explains the 5 seconds on 5 seconds off pattern. The fact that the orange light responds to the f&r switch it sounds exactly like the reverse buzzer wire is hooked to the light. Check this ASAP to confirm. Please feel free to send a phone pic to me at 706-836-7210

PS. Are we absolutely positive this is an IQ and not a Regen2? What's the serial number?
You were correct! Those wires were crossed up but now the buzzer works correctly. One problem taken care of. Looking from underside, they looked right.
omalley is offline   Reply With Quote
Unread 06-08-2012, 08:57 AM   #36
Not Yet Wild
 
Join Date: Jun 2012
Posts: 34
Default Re: DS IQ will not run, NEW batteries just installed

Quote:
Originally Posted by Stevegrmich View Post
Look behind the keyswitch dashplate . . there may/should be another serial number tag there on right side . . .
Found that when I removed the front cowl rechecking the buzzer wiring.

Serial# is AQ0433-419458
So, I have an IQ made the 33rd week of 2004.
omalley is offline   Reply With Quote
Unread 06-08-2012, 09:21 AM   #37
Not Yet Wild
 
Join Date: Jun 2012
Posts: 34
Default Re: DS IQ will not run, NEW batteries just installed

Quote:
Originally Posted by TahoeDawgZ71 View Post
check behind the dash to make sure the buzzer is hooked up like i described. You owe it to yourself to call a dealer and order an Illustrated Parts List for your vehicle. It shows detailed and accurate wiring diagrams that are very easy to read.
I don't have a local dealer or else I would have already visited them. My forehead is nice and bloody from beating my head against the wall trying to figure this out
omalley is offline   Reply With Quote
Unread 06-08-2012, 09:25 AM   #38
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,960
Default Re: DS IQ will not run, NEW batteries just installed

Ok Good. Now we're on to something! Now with the buzzer working properly do this.... Flip car in TOW mode. Charge the cart til the charger turns off. Unplug charger. Flip to RUN. Put in reverse. Buzzer should not sound until car is awake. You must wake the car up by cycling the accel pedal. If this works, it proves that the microswitch in the MCOR is working. If this doesn't wake the car up, you're probably gonna need to put an mcor on it. You can try jumping the 2 pin connector to see if it'll run then.
TahoeDawgZ71 is offline   Reply With Quote
Unread 06-08-2012, 09:37 AM   #39
Not Yet Wild
 
Join Date: Jun 2012
Posts: 34
Default Re: DS IQ will not run, NEW batteries just installed

Quote:
Originally Posted by TahoeDawgZ71 View Post
Ok Good. Now we're on to something! Now with the buzzer working properly do this.... Flip car in TOW mode. Charge the cart til the charger turns off. Unplug charger. Flip to RUN. Put in reverse. Buzzer should not sound until car is awake. You must wake the car up by cycling the accel pedal. If this works, it proves that the microswitch in the MCOR is working. If this doesn't wake the car up, you're probably gonna need to put an mcor on it. You can try jumping the 2 pin connector to see if it'll run then.
I tried jumping the 2 pin connector last night but that didn't accomplish anything. Let me recycle the charger and do what you're telling me and see what happens.

Thanks
omalley is offline   Reply With Quote
Unread 06-08-2012, 09:39 AM   #40
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: DS IQ will not run, NEW batteries just installed

Quote:
Originally Posted by omalley View Post
I don't have a local dealer or else I would have already visited them. My forehead is nice and bloody from beating my head against the wall trying to figure this out
Download a copy of this to your computer:

2004-2005 CC DS Indiv Parts List

. . .
Stevegrmich is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Installed new batteries with Cart in Run Mode...not Tow/Maintenance Electric EZGO
Batteries Installed Backward Electric EZGO
Just Installed New Batteries - What do I need to do Next? Electric EZGO
Installed trojans last night Batteries not charging..... Or maybe they are?.... Electric Club Car
Installed new batteries Electric Club Car


All times are GMT -5. The time now is 08:14 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.