lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-08-2012, 09:45 AM   #41
Not Yet Wild
 
Join Date: Jun 2012
Posts: 34
Default Re: DS IQ will not run, NEW batteries just installed

Quote:
Originally Posted by stevegrmich View Post
download a copy of this to your computer:

2004-2005 cc ds indiv parts list

. . .
THANK YOU!!
omalley is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-08-2012, 09:48 AM   #42
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,025
Default Re: DS IQ will not run, NEW batteries just installed

Quote:
Originally Posted by omalley View Post
I tried jumping the 2 pin connector last night but that didn't accomplish anything. Let me recycle the charger and do what you're telling me and see what happens.

Thanks
Was this when the F&R switch was hooked to the amber light?
TahoeDawgZ71 is offline   Reply With Quote
Unread 06-08-2012, 09:58 AM   #43
Not Yet Wild
 
Join Date: Jun 2012
Posts: 34
Default Re: DS IQ will not run, NEW batteries just installed

Quote:
Originally Posted by TahoeDawgZ71 View Post
Was this when the F&R switch was hooked to the amber light?
As I sheepishly shake my head, yes.
omalley is offline   Reply With Quote
Unread 06-08-2012, 11:48 AM   #44
Not Yet Wild
 
Join Date: Jun 2012
Posts: 34
Default Re: DS IQ will not run, NEW batteries just installed

Quote:
Originally Posted by TahoeDawgZ71 View Post
Ok Good. Now we're on to something! Now with the buzzer working properly do this.... Flip car in TOW mode. Charge the cart til the charger turns off. Unplug charger. Flip to RUN. Put in reverse. Buzzer should not sound until car is awake. You must wake the car up by cycling the accel pedal. If this works, it proves that the microswitch in the MCOR is working. If this doesn't wake the car up, you're probably gonna need to put an mcor on it. You can try jumping the 2 pin connector to see if it'll run then.
Do I have to wait for the batteries to fully charge? I went ahead and disconnected the charger, flipped from tow to run and clicked reverse. The buzzer came on immediately without me touching the gas pedal.

Got the charger back on to finish out charging, just wanted to try to have this buttoned up for the weekend.
omalley is offline   Reply With Quote
Unread 06-08-2012, 02:31 PM   #45
Not Yet Wild
 
Join Date: Jun 2012
Posts: 34
Default Re: DS IQ will not run, NEW batteries just installed

Charge is complete, disconnected charger, switched from tow to run, switched to R and the buzzer immediately came on, didn't touch the pedal. Also noticed that when I switch the tow/run switch from tow to run, I hear and feel the solenoid click on then about 2-3 seconds later the solenoid clicks off. Sound like the MCOR??
omalley is offline   Reply With Quote
Unread 06-08-2012, 03:13 PM   #46
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,025
Default Re: DS IQ will not run, NEW batteries just installed

It's strange that the car isnt going into sleep mode. So we've confirmed that the solenoid responds to the pedal now, so No it doesn't sound like an MCOR issue unless it's related to throttle frequency. Now that you've got that alltrax controller on it I'd invest in the programming cable for a few bucks and plug your laptop in and see what it tells you. I'd be able to help you more if you had the old Curtis still on it but with the Alltrax I can't help you much because I've never played with their software.
TahoeDawgZ71 is offline   Reply With Quote
Unread 06-08-2012, 04:11 PM   #47
Not Yet Wild
 
Join Date: Jun 2012
Posts: 34
Default Re: DS IQ will not run, NEW batteries just installed

Quote:
Originally Posted by TahoeDawgZ71 View Post
It's strange that the car isnt going into sleep mode. So we've confirmed that the solenoid responds to the pedal now, so No it doesn't sound like an MCOR issue unless it's related to throttle frequency. Now that you've got that alltrax controller on it I'd invest in the programming cable for a few bucks and plug your laptop in and see what it tells you. I'd be able to help you more if you had the old Curtis still on it but with the Alltrax I can't help you much because I've never played with their software.
NO! the solenoid does NOT actuate with the pedal. It would initially engage then disengage when I flipped the tow switch to go. It does not do this now. I f'n HATE electrical gremlins!
omalley is offline   Reply With Quote
Unread 06-08-2012, 09:03 PM   #48
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,025
Default Re: DS IQ will not run, NEW batteries just installed

The solenoid shouldn't respond to the tow switch at all. Get the alltrax software. You need it bad.
TahoeDawgZ71 is offline   Reply With Quote
Unread 06-08-2012, 09:09 PM   #49
Not Yet Wild
 
Join Date: Jun 2012
Posts: 34
Default Re: DS IQ will not run, NEW batteries just installed

Will do. Previous post wasn't written with malice, just a lot of frustration. Thanks for all of your help
omalley is offline   Reply With Quote
Unread 06-11-2012, 02:02 PM   #50
Not Yet Wild
 
Join Date: Jun 2012
Posts: 34
Default Re: DS IQ will not run, NEW batteries just installed

Well, I hooked up the computer to the controller and didn't see anything out of the ordinary. No error codes were thrown or flagged. However, It didn't see the throttle position so there wasn't any output or battery current to monitor. So, looks like the MCOR?? Is there a test or a procedure that I need to do now?
omalley is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Installed new batteries with Cart in Run Mode...not Tow/Maintenance Electric EZGO
Batteries Installed Backward Electric EZGO
Just Installed New Batteries - What do I need to do Next? Electric EZGO
Installed trojans last night Batteries not charging..... Or maybe they are?.... Electric Club Car
Installed new batteries Electric Club Car


All times are GMT -5. The time now is 03:10 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.