lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars

Post New Thread  Reply
Thread Tools Display Modes
Unread 06-12-2012, 06:25 AM   #1
Not Yet Wild
Join Date: Jun 2012
Posts: 3
Question 92 V-Glide has 26 volts through the frame

Not sure why I have voltage through the frame? The cart has multiple problems that I am trying to work out. First:
1. Key switch inop. There is no power coming from the wires to the switch on either side of it. There was like 7 mV actually. So as I lay the switch down it touches the aluminum strip on the dass and arcs. I checked from the battery negative to the frame and had 26 volts going through it. Is this normal or is there a short to ground some where and could this be causing multiple issues that i have.

I will just list the ones I know of.

1. cart goes in fwd as soon as I put it in fwd w/out pushing the throttle.
2. cart has no reverse
3. batteries dying really fast
4. key switch inop

Thanks for your help
Joe Carreras is offline   Reply With Quote
Alt Today

Golf car forum Sponsored Links

This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
Unread 06-12-2012, 09:17 AM   #2
The Last Moja Morani
shadowman's Avatar
Club Car
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 92 V-Glide has 26 volts through the frame

no there should be no voltage going thur to the cause it could be a # of things but start by really cleaning the battery tray...............test and load test each battery make sure your dealing with good batteries......if your working on cart and have to remove dash YOU CAN NOT LET ANYTHING TOUCH FRAME AND SPARK that how you take out complete wiring harness,s and controllers and a bunch of other stuff..............#1 you have a solenoid problem........#2 could be a few things ( a microswitch....wires or cables hooked up wrong ) #3 as i said up top you need to test and load test each battery...............#4 you need a new,ll get further ahead if you do these things 1 at a time like !st get a new keyswitch and while your waiting on it take care of battery problems and clean tray.........also get a wiring diagram make sure its all wired right than work on solenoid and reverse........................................... ..
shadowman is offline   Reply With Quote
Unread 06-12-2012, 10:10 AM   #3
Gone Wild
Join Date: Dec 2010
Posts: 429
Default Re: 92 V-Glide has 26 volts through the frame

Being an old cart there is a good chance of there being a carbon build up in the motor from the brushes that can cause an earth leak.
Golfdog is offline   Reply With Quote
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car

Thread Tools
Display Modes

Similar Threads
Thread Forum
six 8-volts versus eight 6-volts Electric EZGO
Changing 8 volts for 12 volts Electric Club Car
36 volts..12 volts accessories..?? Electric Club Car
Can I put 48 volts in a Club Car with V-Glide? Electric Club Car
V-Glide doesn't glide - 1992 36v Electric Club Car

All times are GMT -5. The time now is 03:55 AM.

Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.