lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-15-2012, 05:00 PM   #1
Getting Wild
 
Ronniek's Avatar
E-Z-GO
 
Join Date: Aug 2011
Location: Lancaster,SC
Posts: 79
Default Another Problem HELP!

My 1st message this morning: (This was last week)

[98 Club Car 48 volts. Charger comes on & charges fine up to halfway on the needle. Then the needle stops moving but it continue to charge. I left it running over night & when checking I could hear the batteries bubbling & it was only showing halfway after charging all night. Checking across the batteries (1st to last + & -) it showed 54v. Do I have a bad charger or what?]

New Problem: (Today)

WOW, went to move cart, pressed pedal & it lunged about 6" & quit. It had done something similar a few times but would always continue to go. (Pedal has always had a little jerk to it). This time nothing but clicking from solenoid in F & R. Low battery light would blink when pressing pedal. Then after a few presses now nothing! Plugged charger in & it clicks but the needle never goes anywhere. You can feel the charger & tell it's on but no charge on the needle. Even the headlights don't work & I think their on a direct wire to a battery (fuse is good). Meter on each battery shows 8.2 - 8.5 (48v) 1998 club car. Overall had a 48.2 (I checked this using the POS from motor & NEG from motor on the 2 batteries.)

HELP! Please!
Ronnie
Ronniek is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-15-2012, 11:06 PM   #2
Not Yet Wild
Club Car
 
Join Date: Aug 2009
Location: Roseville, MI
Posts: 62
Default Re: Another Problem HELP!

I think the OBC controls the charger, I would start there
Dav1774 is offline   Reply With Quote
Unread 06-16-2012, 09:27 PM   #3
Getting Wild
 
Ronniek's Avatar
E-Z-GO
 
Join Date: Aug 2011
Location: Lancaster,SC
Posts: 79
Default Re: Another Problem HELP!

Had a friend come over to help figure out what is going on. Went thru the steps to reset the OBC, didn't help. He was looking & guess what he found....... A battery cable was hanging on by just a couple of wire strands! Went & got a spare cable from him & Ta-Da!!! All is right.
Ronniek is offline   Reply With Quote
Unread 06-16-2012, 09:36 PM   #4
Gone Wild
 
Down South's Avatar
Club Car
 
Join Date: Aug 2011
Location: La but staying in Houston most of the time
Posts: 554
Default Re: Another Problem HELP!

Quote:
Originally Posted by Ronniek View Post
Had a friend come over to help figure out what is going on. Went thru the steps to reset the OBC, didn't help. He was looking & guess what he found....... A battery cable was hanging on by just a couple of wire strands! Went & got a spare cable from him & Ta-Da!!! All is right.
I think that I would look into the purchase of a whole new set of battery cables.
Down South is offline   Reply With Quote
Unread 06-16-2012, 11:22 PM   #5
Getting Wild
 
Ronniek's Avatar
E-Z-GO
 
Join Date: Aug 2011
Location: Lancaster,SC
Posts: 79
Default Re: Another Problem HELP!

Gonna order a set tomorrow!
Ronniek is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Good problem bad problem Big Block Talk!


All times are GMT -5. The time now is 09:31 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.