lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-16-2012, 12:04 AM   #1
Not Yet Wild
Club Car
 
Join Date: Jun 2012
Location: Rowland, NC
Posts: 6
Default 81 DS won't run

I bought a 1981 ds today and it won't run. When I switch it on and select a gear, it moves an inch or two without touching the pedal and then just clicks when I depress the pedal. I also notice a spark in the selector switch when it moves from neutral. The coils also put off a good deal of heat that seems to me to be a problem. The previous owner said he feels it needs batteries but claimed it would run 2 or 3 hours on these last fall. Thanks in advance for your help.
royforce is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-16-2012, 09:47 PM   #2
Not Yet Wild
Club Car
 
Join Date: Jun 2012
Location: Rowland, NC
Posts: 6
Default Re: 81 DS won't run

O.K. So today I charged it up for a while and when I jack up the rear, it will run forward when you shift it, without pressing the accelerator. Thanks in advance again.
royforce is offline   Reply With Quote
Unread 06-16-2012, 11:50 PM   #3
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,079
Default Re: 81 DS won't run

Test the F&R and all the micro switches. There are a few problems ; solenoid may be welded closed? Start there...
scottyb is offline   Reply With Quote
Unread 06-17-2012, 08:01 PM   #4
Not Yet Wild
 
Join Date: Mar 2012
Posts: 7
Default Re: 81 DS won't run

when mine did that it was the solenoids.. i replaced them allruns just fine now ..
duck67 is offline   Reply With Quote
Unread 06-17-2012, 08:01 PM   #5
Not Yet Wild
 
Join Date: Mar 2012
Posts: 7
Default Re: 81 DS won't run

when mine did that it was the solenoids.. i replaced them all runs just fine now ..
duck67 is offline   Reply With Quote
Unread 06-17-2012, 09:39 PM   #6
Not Yet Wild
Club Car
 
Join Date: Jun 2012
Location: Rowland, NC
Posts: 6
Default Re: 81 DS won't run

Thanks fellas... I'm gonna take it to the shop this week and let them get it straight. This cart is in kind of rough shape, but I think I'm gonna get it running first and deal with the cosmetics later.
royforce is offline   Reply With Quote
Unread 06-18-2012, 06:22 PM   #7
Getting Wild
 
wbwood's Avatar
Club Car
 
Join Date: Apr 2012
Location: Mooresville, NC
Posts: 100
Default

Hope you got a good deal on it. Lol
wbwood is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes



All times are GMT -5. The time now is 08:40 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.