lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-24-2012, 06:01 PM   #11
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: Two questions about my 08 Precedent

Quote:
Originally Posted by kvl1027 View Post
Well, now I have a new problem. I disconnected one of the cables from the batteries because there was some corrosion. I cleaned the terminal and the cable and put it back and now the cart does not run.

Also, there is a very quiet clicking noise coming from one of the batteries, kind of scary. It is making the noise whether it is hooked up or not. Not sure what the hell is going on. Can someone help?

I should add, that I dropped one of the hex nuts that was holding the cable and had to leave the cable disconnected most of the day until I could get a replacement nut. (I could not find the nut I dropped, it disappeared.....) Could it be possible that breaking the circuit could drain the batteries somehow? Just throwing that out there.

Also, when I was cleaning one of the I used a wire brush and got a small spark. Could I have caused a short, is there a fuse somewhere I should check? I'm a complete noob here, sorry if I sound naive.

I have the cart plugged into the charger and it is charging, so when it kicks off I will give it another try.

Did you put the cart in tow when working on the batteries?
erict is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-25-2012, 08:25 AM   #12
Getting Wild
 
kvl1027's Avatar
Club Car
 
Join Date: Jun 2012
Location: Sebring, FL
Posts: 123
Default Re: Two questions about my 08 Precedent

Quote:
Originally Posted by erict View Post
Did you put the cart in tow when working on the batteries?
I did put it in tow.

It seems to be working fine now. I guess somehow the batteries were drained, because after it was charged for only 30 minutes everything was working fine.

So everything appears to be working normally and after cleaning the terminals the cart is no longer stuttering at top speed, so that must have been it. Thanks for the help everyone.
kvl1027 is offline   Reply With Quote
Unread 07-01-2012, 08:59 PM   #13
Getting Wild
 
kvl1027's Avatar
Club Car
 
Join Date: Jun 2012
Location: Sebring, FL
Posts: 123
Default Re: Two questions about my 08 Precedent

Quote:
Originally Posted by kvl1027 View Post
I did put it in tow.

It seems to be working fine now. I guess somehow the batteries were drained, because after it was charged for only 30 minutes everything was working fine.

So everything appears to be working normally and after cleaning the terminals the cart is no longer stuttering at top speed, so that must have been it. Thanks for the help everyone.
We, I guess it did not solve the problem. What else could it be?
kvl1027 is offline   Reply With Quote
Unread 07-03-2012, 11:00 PM   #14
Getting Wild
Club Car
 
Join Date: Aug 2011
Location: Western Michigan
Posts: 87
Default Re: Two questions about my 08 Precedent

I would check the pack voltage or mcor.
Dhenryjr is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Precedent lift kit questions. Gas Club Car
Precedent I2 Motor Questions Electric Club Car
2007 Precedent questions/issues Electric Club Car
05 Precedent Lift questions Lifted Golf Carts
questions on 05' Precedent Electric Club Car


All times are GMT -5. The time now is 01:47 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.