lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-25-2012, 10:10 AM   #1
Not Yet Wild
 
Join Date: Jul 2010
Posts: 14
Default 2000 ds moving slowly, no power

Hi all,
I have a 2000 DS. Last year I was having trouble with the regen system so I unplugged the pigtail. Cart ran fine. This year we opened up camp and the cart felt slow. This week the cart was running real slow with no power on the hills. The batteries were 6 years old but where reading between 9 and 9.13 each, after being charged. I decided to change out the batteries due to the age and the fact that I don't have a load tester. Well the cart still has no power and almost comes to a complete stop on the hills. The trottle is slow to respond. I also changed out the cables last year. The ground cable that goes through the black box was not changed. What should I check next?
Thank you
Bill
bduece is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-25-2012, 10:32 AM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 2000 ds moving slowly, no power

this sounds like for some reason the reagan is staying engaged......get on cart and drive it 50 ft or so then get off lift seat and see if resistor coil on reagan solenoid is glowing red...............................
shadowman is offline   Reply With Quote
Unread 06-26-2012, 08:25 AM   #3
Not Yet Wild
 
Join Date: Jul 2010
Posts: 14
Default Re: 2000 ds moving slowly, no power

Thank you, I will check that.
bduece is offline   Reply With Quote
Unread 07-01-2012, 12:59 PM   #4
Not Yet Wild
 
Join Date: Jul 2010
Posts: 14
Default Re: 2000 ds moving slowly, no power

Ok, so I'm in Maine with the cart and yes the resister is glowing red. The solenoid doesn't appear to be working. Since I disconnected the regen on the motor, can I jump this solenoid and leave it out of the system?
bduece is offline   Reply With Quote
Unread 07-01-2012, 02:14 PM   #5
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 2000 ds moving slowly, no power

i,m not certain but i don,t think so .......i beleve theres more to it than just taking solenoid out of system, i mean you can try but if it will work?? if you do and it does post result..................................
shadowman is offline   Reply With Quote
Unread 07-01-2012, 03:05 PM   #6
Not Yet Wild
 
Join Date: Jul 2010
Posts: 14
Default Re: 2000 ds moving slowly, no power

I moved both white wires to the same post and it is moving normally. Let's see for how long.
bduece is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Pulling power for 2000 pounds Gas golf carts
Engine slowly losing power Gas EZGO
2000 TXT lacks power Gas EZGO
2000 EzGo TXT 295 - No Power Gas EZGO
2000 TXT No power? Electric EZGO


All times are GMT -5. The time now is 03:16 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.