lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-27-2012, 04:34 PM   #1
Not Yet Wild
 
Join Date: Apr 2012
Posts: 9
Default Multiple problems?

I purchased an 02 ds iq cart last week. Everything seemed fine, batteries were new in 09 and everything functioned well. I purchased a back seat and lift kit and finished installing them yesterday. I added a little distilled water to the batteries, the water level was a little low but not at or below the cells. Jumped on it for a test ride and nothing... No forward or reverse. Reverse buzzer is working, battery light was on, solenoid is clicking but no go... I decided to then plug it in to the charger thinking maybe the batteries are drained or adding the distilled water changed things. Plugged it in almost 24 hrs ago and she is still charging. When I left for work today the meter on the charger was below 5 but now it is back up to 6ish. How long should I let it keep charging? New to this cart world and am just looking for a little advice. Thanks in advance for your reply!
JAG3 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-27-2012, 04:40 PM   #2
Not Yet Wild
 
Join Date: Apr 2012
Posts: 9
Default Re: Multiple problems?

On second thought, the first week of owning the cart I did notice the back up buzzer had a mind of its own. It would periodically come on and shut off when the cart was in reverse. Maybe this helps...
JAG3 is offline   Reply With Quote
Unread 06-27-2012, 05:42 PM   #3
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Multiple problems?

charger should shut off regardless at 16 hours........and cart not running it sounds like you have an OBC issue..............................
shadowman is offline   Reply With Quote
Unread 06-27-2012, 05:48 PM   #4
Not Yet Wild
 
Join Date: Apr 2012
Posts: 9
Default Re: Multiple problems?

I have seen posts regarding an obc reset. Should I try that?
JAG3 is offline   Reply With Quote
Unread 06-27-2012, 05:50 PM   #5
Not Yet Wild
 
Join Date: Apr 2012
Posts: 9
Default Re: Multiple problems?

Unplugged it and still no go. Solenoid click and it sounds like the motor is whining trying to start but nothing. Thanks
JAG3 is offline   Reply With Quote
Unread 06-27-2012, 05:56 PM   #6
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,025
Default Re: Multiple problems?

Plug the wires back into the controller that came unplugged when you lifted the rear of the cart. One is orange, and one is blue.
TahoeDawgZ71 is online now   Reply With Quote
Unread 06-27-2012, 05:58 PM   #7
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Multiple problems?

ok then you need to check voltage in batteries.......if motor is whining you have a battery problem.................check voltage in each battery and if needed load test each one i bet you,ll find your problem....also check all cables make sure all are clean and good and tight.......clean as a new penney.............................
shadowman is offline   Reply With Quote
Unread 06-27-2012, 06:16 PM   #8
Not Yet Wild
 
Join Date: Apr 2012
Posts: 9
Default Re: Multiple problems?

Tahoedawg you rock! Both the orange and blue wires are unplugged. Hopefully this will fix all! Which wire goes on top?
JAG3 is offline   Reply With Quote
Unread 06-27-2012, 08:07 PM   #9
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Multiple problems?

Quote:
Originally Posted by TahoeDawgZ71 View Post
Plug the wires back into the controller that came unplugged when you lifted the rear of the cart. One is orange, and one is blue.
david........you da man........................................
shadowman is offline   Reply With Quote
Unread 06-27-2012, 08:33 PM   #10
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,081
Default Re: Multiple problems?

Lol> TD
scottyb is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Charging Multiple 48v Carts Electric Club Car
Multiple Marathon Questions. Gas EZGO
possble battery problems or possible charger problems? Extreme DC!
6 passanger trouble shooting. Controller problems/gas/or brake problems. Electric EZGO
Help with multiple problems. Electric EZGO


All times are GMT -5. The time now is 11:28 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.