lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-07-2012, 08:41 PM   #1
Not Yet Wild
 
Join Date: Jul 2012
Posts: 2
Default 06 Club Car Precedent lights not working

With the key in the on position and the lights switch pulled out: no lights work. When I disconnect the cable from the dash to the front lights, the back lights begin to work. (This cable is coming from my dash and the connection is behind the front light kit.) Car works great otherwise! Any help would be appreciated.
paulzani is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-08-2012, 09:42 AM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 06 Club Car Precedent lights not working

any fuses? you need to just start tracing wires.......be careful if taking dash off disconnect main power from batteries...................................
shadowman is offline   Reply With Quote
Unread 07-08-2012, 11:35 AM   #3
Not Yet Wild
 
Join Date: Jul 2012
Posts: 2
Default Re: 06 Club Car Precedent lights not working

consider me a cart novice...not sure what the fuse looks like? there is a white connector with six holes in it that joins the two wires (from dash to front light kit.) is the fuse in that? There is also a black square thing near the batteries. there are blue wires attached to both sides of it - it has a button that is spring loaded (like a reset) on it....
paulzani is offline   Reply With Quote
Unread 07-08-2012, 01:01 PM   #4
Gone Wild
 
DJBlade's Avatar
Club Car
 
Join Date: Dec 2011
Location: Columbia, South Carolina
Posts: 258
Default Re: 06 Club Car Precedent lights not working

Quote:
Originally Posted by paulzani View Post
consider me a cart novice...not sure what the fuse looks like? there is a white connector with six holes in it that joins the two wires (from dash to front light kit.) is the fuse in that? There is also a black square thing near the batteries. there are blue wires attached to both sides of it - it has a button that is spring loaded (like a reset) on it....
The spring loaded button you refer to is the circuit breaker for the lights. I don't think that is the problem since when you disconnect the front lights, the rears start working. All the power comes through that blue wire. It sounds to me like there is a short in the wiring harness for the front lights. When you disconnect that harness that leads to the front lights the others work. I would find a Club Car dealer and ask if you could switch out that harness to see if that is the problem. Then if it is, buy it.
DJBlade is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2002 Club Car Lights not working Electric Club Car
2010 Club Car Precedent Brake Lights Not Working Electric Club Car
Lights not working on '09 Precedent Electric Club Car
07 Club Car Precedent---Lights stopped working after new batteries installed Electric Club Car


All times are GMT -5. The time now is 12:59 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.