lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-09-2012, 07:15 PM   #1
Not Yet Wild
Club Car
 
Join Date: Jul 2012
Location: North Carolina
Posts: 10
Unhappy 2007 Precedent stops after going 10'

My son gave me a 2007 Club car Precedent. When I try to go forward it will travel about 10 - 15 feet and stop. I release the gas and then push it down again and it will go forward. All the batteries test at 12 volts. What steps should I take to find the problem. I am familiar with automobile repair but have never worked on a golf cart.
Buzz34453 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-09-2012, 07:23 PM   #2
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: 2007 Precedent stops after going 10'

Quote:
Originally Posted by Buzz34453 View Post
My son gave me a 2007 Club car Precedent. When I try to go forward it will travel about 10 - 15 feet and stop. I release the gas and then push it down again and it will go forward. All the batteries test at 12 volts. What steps should I take to find the problem. I am familiar with automobile repair but have never worked on a golf cart.
Could be either speed sensor which is located at to end of the motor or MCOR which is located under the go pedal. I would charge the batteries then wait 12 hours at take and post readings. I would also do a load test on them. Batteries create 80% of problems so you want to make sure they are good.
erict is offline   Reply With Quote
Unread 07-10-2012, 09:52 AM   #3
Not Yet Wild
Club Car
 
Join Date: Jul 2012
Location: North Carolina
Posts: 10
Default Re: 2007 Precedent stops after going 10'

Took a reading this morning on batteries without load are total 49.4. Battery 1/12.53 2/12.45 3/12.40 4/12.39 Under load they dropped to 48.3
Buzz34453 is offline   Reply With Quote
Unread 07-10-2012, 11:19 AM   #4
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: 2007 Precedent stops after going 10'

Quote:
Originally Posted by Buzz34453 View Post
Took a reading this morning on batteries without load are total 49.4. Battery 1/12.53 2/12.45 3/12.40 4/12.39 Under load they dropped to 48.3
Batteries are only at 70% after a full charge. Just may be a battery issue causing your problem?
erict is offline   Reply With Quote
Unread 07-10-2012, 12:20 PM   #5
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 2007 Precedent stops after going 10'

also keep in mind that year could be m-cor or speed sensor related........................................... .....
shadowman is offline   Reply With Quote
Unread 07-10-2012, 06:49 PM   #6
Not Yet Wild
Club Car
 
Join Date: Jul 2012
Location: North Carolina
Posts: 10
Default Re: 2007 Precedent stops after going 10'

So my batteries are only at 70% with those readings? It was 12 hours after being charged like you said to do. How do I know if it is MCOR or speed sensor?
Buzz34453 is offline   Reply With Quote
Unread 07-10-2012, 07:44 PM   #7
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: 2007 Precedent stops after going 10'

Quote:
Originally Posted by Buzz34453 View Post
So my batteries are only at 70% with those readings? It was 12 hours after being charged like you said to do. How do I know if it is MCOR or speed sensor?
Correct. Here is a state of charge chart. Batteries are getting weak.
State of Charge Readings

I'm not sure on the MCOR test. To do the speed sensor test, turn key "on" then put in gear, forward, then get off the cart and see if you are able to push it. If it pushes freely/easily, bad sensor. If it has resistance when trying to push it, good sensor.
erict is offline   Reply With Quote
Unread 07-10-2012, 08:22 PM   #8
Not Yet Wild
Club Car
 
Join Date: Jul 2012
Location: North Carolina
Posts: 10
Default Re: 2007 Precedent stops after going 10'

Thank you very much. I will follow through with the test tomorrow. You think all of the batteries need to be replaced then.
Buzz34453 is offline   Reply With Quote
Unread 07-10-2012, 08:25 PM   #9
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: 2007 Precedent stops after going 10'

Quote:
Originally Posted by Buzz34453 View Post
Thank you very much. I will follow through with the test tomorrow. You think all of the batteries need to be replaced then.
Even though your batteries are getting weaker the cart should still move but wont have as long of run time. I would do the speed sensor test and if it is OK then I might look at the MCOR.

When you take your foot off the pedal and press it again, how far does the cart go the second time?
erict is offline   Reply With Quote
Unread 07-10-2012, 08:52 PM   #10
Not Yet Wild
Club Car
 
Join Date: Jul 2012
Location: North Carolina
Posts: 10
Default Re: 2007 Precedent stops after going 10'

Just about 10 feet each time I press on the pedal. Maybe a little farther but no more than 20 feet.
Buzz34453 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2007 Precedent Electric Club Car
2007 precedent stops at full pedal Electric Club Car
05 precedent stops suddenly then starts working again Electric Club Car
2007 Precedent vs DS Electric Club Car
2007 CC precedent needs new batteries Electric Club Car


All times are GMT -5. The time now is 06:36 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.