lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-18-2012, 09:35 AM   #1
Not Yet Wild
 
Join Date: Jul 2012
Posts: 3
Default headlights don't work

Hey all, new here, new to golf cars and have a question.
My 2002 club car headlights both quit working at the same time, the tail lights still work and I wanted to see if anyone has an idea before I start tearing into wires. Could both bulbs have gone bad at the same time? Is it the switch? Are there any fuses / fuse box on this car?
thanks in advance
warrior1999 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-18-2012, 10:40 AM   #2
Carts Unlimited
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: So Cal
Posts: 50,924
Default Re: headlights don't work

Check any fuses you can find under the seat in the battery bay..... then pull the dash and check voltage at the light switch....... then check the switch operation.

Both lights will burn out at once if somebody connects them to 36v instead of 12
scottyb is offline   Reply With Quote
Old 07-18-2012, 01:49 PM   #3
Not Yet Wild
 
Join Date: Oct 2010
Posts: 34
Default Re: headlights don't work

one other search - check and make sure you have a good ground connection.
Sometimes the aluminium frame on club cars does not give a good ground.
2jacksmax is offline   Reply With Quote
Old 07-18-2012, 01:54 PM   #4
Gone Wild
 
DJBlade's Avatar
Club Car
 
Join Date: Dec 2011
Location: Columbia, South Carolina
Posts: 219
Default Re: headlights don't work

...and believe it or not, I have seen both bulbs blow at the same time. Check the bulbs out too.
DJBlade is offline   Reply With Quote
Old 07-18-2012, 01:56 PM   #5
Gone Wild
 
camaroluvz28's Avatar
Yamaha
 
Join Date: Sep 2010
Location: Florida
Posts: 839
Default Re: headlights don't work

Quote:
Originally Posted by 2jacksmax View Post
one other search - check and make sure you have a good ground connection.
Sometimes the aluminium frame on club cars does not give a good ground.
As this is in the electric carts section I hope your lights are not grounded to frame anyway...Never ground to frame on an electric vehicle, always ground to battery negative...
camaroluvz28 is offline   Reply With Quote
Old 07-18-2012, 02:43 PM   #6
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 3,577
Default Re: headlights don't work

Quote:
Originally Posted by camaroluvz28 View Post
As this is in the electric carts section I hope your lights are not grounded to frame anyway...Never ground to frame on an electric vehicle, always ground to battery negative...
Exactly. This IS an electric car right? Because if it's a gas car I think I know exactly what's causing your problem
TahoeDawgZ71 is offline   Reply With Quote
Old 07-19-2012, 09:18 AM   #7
Not Yet Wild
 
Join Date: Jul 2012
Posts: 3
Default Re: headlights don't work

thanks for the responses, yes it is electric, I suspect the switch but thought first about a fuse except I can't find any fuses???? Where are they?
warrior1999 is offline   Reply With Quote
Old 07-19-2012, 10:42 AM   #8
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 3,577
Default Re: headlights don't work

By tail lights do you mean the rear brake lights or the running lights when you pull the switch on? If the running lights still work you don't have a fuse problem. The headlights and running lights work on the same fuse. If one works, they both should work. I'd pull a bulb loose and check for power at the wires that plug into the bulb with the light switch on.
TahoeDawgZ71 is offline   Reply With Quote
Old 07-19-2012, 11:01 AM   #9
Gone Wild
 
camaroluvz28's Avatar
Yamaha
 
Join Date: Sep 2010
Location: Florida
Posts: 839
Default Re: headlights don't work

Also we have never established if these are factory lights or aftermarket...If aftermarket i would look for where someone has connected both lights with a butt connector to only run one wire up to switch or to battery negative and make sure there is no bad connection there.
camaroluvz28 is offline   Reply With Quote
Old 07-19-2012, 05:32 PM   #10
Not Yet Wild
 
Join Date: Jul 2012
Posts: 3
Default Re: headlights don't work

OK, now I guess you guys have narrowed it down for me, thanks so much.
They are factory headlights and the running tail lights do work so it looks like my likely problem is both headlight bulbs, correct me if I'm wrong.
PS I'm glad it's not a fuse 'cause I can't find any fuses!!!
thanks again
warrior1999 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZ go headlights Electric EZGO
Headlights Work When CC IS NOT Going Electric Club Car
Headlights Gas Club Car
No Headlights and Reverse Doesn't Work Electric EZGO
headlights set up Electric EZGO


All times are GMT -5. The time now is 01:57 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.