lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-18-2012, 12:45 PM   #1
Not Yet Wild
 
Join Date: Oct 2010
Posts: 34
Default stereo ???

I have installed several CD / radio players in the past but today I have an wierd situation that I may need some expertise on.
installed a player - CD's play great / MP player works great / tuner does not come in well.
put a stronger antenna on and still not much on tuner. -- similar player install on car next to this one and tuner plays great so signal strength should not be the cause??
siwtch radios and still no improvement. I have 12 volts coming from the converter..
any ideas as to what maybe going on ???
2jacksmax is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-18-2012, 08:45 PM   #2
Gone Wild
 
SaltLifeCC's Avatar
 
Join Date: Jun 2010
Posts: 729
Default Re: stereo ???

There are reasons for that on an electric cart and maybe even some things you can find with a search to help it. But I don't think you'll get it as good as a car job no matter what. I don't know the specifics but I've read about the issue here before and have experienced it myself. For me, I wasn't really looking for a tuner anyway. I bought it primarily to play iPhones through (all 4 of us have one in my family) and secondarily to play CD's. I found an antenna that was made specifically to hide inside the fairing of a motorcycle and it fit great insde the front body of my cart. But a radio station has to be coming in pretty strong to get a good signal to the tuner on my Kenwood.
SaltLifeCC is offline   Reply With Quote
Unread 07-27-2012, 11:29 AM   #3
Not Yet Wild
 
Join Date: Oct 2010
Posts: 34
Default Re: stereo ???

I agree with the logic its just that this was the first time I was not getting a good signal when installing stereos. I have put in several pioneers and kenwoods before on golf cars and boats.
2jacksmax is offline   Reply With Quote
Unread 07-27-2012, 01:14 PM   #4
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,966
Default Re: stereo ???

I've never gotten a good signal on an electric cart. Gas carts are a different story. I'm guessing because they utilize a frame ground much like an automobile.
TahoeDawgZ71 is offline   Reply With Quote
Unread 07-27-2012, 01:40 PM   #5
Gone Wild
 
camaroluvz28's Avatar
Yamaha
 
Join Date: Sep 2010
Location: Florida
Posts: 932
Default Re: stereo ???

Quote:
Originally Posted by TahoeDawgZ71 View Post
I've never gotten a good signal on an electric cart. Gas carts are a different story. I'm guessing because they utilize a frame ground much like an automobile.
Never thought about that fact...but I have noticed a weak signal on almost all electric carts also...
camaroluvz28 is offline   Reply With Quote
Unread 07-29-2012, 06:37 PM   #6
Getting Wild
 
hanny's Avatar
 
Join Date: May 2012
Posts: 111
Default Re: stereo ???

Quote:
Originally Posted by camaroluvz28 View Post
Never thought about that fact...but I have noticed a weak signal on almost all electric carts also...
first gotta be sure you dont use the body as a ground. run pos and neg wires directly to the one battery or better yet convertor. On cars the antenna being mounted seems to help where as on carts it doesnt seem that way. I mount mine on the plastic roof,,, still not great
hanny is offline   Reply With Quote
Unread 07-29-2012, 07:13 PM   #7
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: stereo ???

Would this still be an issue with a separate battery just for the radio so it's isolated from the pack?
erict is offline   Reply With Quote
Unread 07-29-2012, 07:28 PM   #8
Not Yet Wild
 
Join Date: Jul 2012
Posts: 16
Default Re: stereo ???

A regular auto radio antenna will probably not work well. An auto antenna is really just half of an antenna. It relies on the body (metal or frame) to be the other half.

If you look in a marine cataloq or a website, you will see AM/FM antennas made to be used with fiberglass bodies. They are basically dipole antennas with both halves being wire wrapped around or in a mast. These are also available for RV's and 18 wheelers, try a big truckstop. An indoor FM radio antenna usually made of just TV twin lead would also probably work. Just hide the antenna under the roof or in the dash, but keep it away from metal as much as possible.
lampooner1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Stereo in a G1 Gas Yamaha
stereo Electric Club Car
Help with 97 DS stereo Gas Club Car
ez go pds stereo? Electric EZGO
Stereo for a G1 ? Gas Yamaha


All times are GMT -5. The time now is 03:28 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.