lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-22-2012, 08:09 PM   #1
The Fabricator
 
Xtreme Cartz's Avatar
 
Join Date: Dec 2006
Posts: 2,012
Default VGlide Club Car only has one speed...FAST

I have a club car that when you press the pedal down it only runs wide open, leaving a trail of tire marks in the grass. The torque is admirable but it has no speed variation. I understand that on a normal operating vglide, the pedal pressed all the way down bypasses all resistors in the circuit. So Im wondering what could make it run WOT no matter how far the pedal is pressed?
Xtreme Cartz is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-23-2012, 11:35 AM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: VGlide Club Car only has one speed...FAST

have you opened v-glide and looked at the moveable arm and the copper shoes? .....................................
shadowman is offline   Reply With Quote
Unread 07-24-2012, 08:11 PM   #3
The Fabricator
 
Xtreme Cartz's Avatar
 
Join Date: Dec 2006
Posts: 2,012
Default Re: VGlide Club Car only has one speed...FAST

Yes with the cover off I pressed the accelerator and a spark came from the vglide. I tightened the connections and it runs fine now. Not sure if that was a coincidence or the actual problem.
Xtreme Cartz is offline   Reply With Quote
Unread 07-25-2012, 06:02 AM   #4
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: VGlide Club Car only has one speed...FAST

Quote:
Originally Posted by Xtreme Cartz View Post
Yes with the cover off I pressed the accelerator and a spark came from the vglide. I tightened the connections and it runs fine now. Not sure if that was a coincidence or the actual problem.
. . . probably the actual problem . . .
Stevegrmich is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Club car has 1 speed.... FAST!!! Electric Club Car
1981 club car slow speed fast speed Electric Club Car
1979 Club Car only has one speed---FAST again.... Electric Club Car
1979 Club Car only has one speed---FAST Electric Club Car
Speed from 97 CC Vglide 36V Electric Club Car


All times are GMT -5. The time now is 07:34 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.