lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-04-2012, 11:55 PM   #21
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,962
Default Re: 2007 Precedent not charging...

I think it may be something even more simple than we think. Check the wall outlet where the charger is plugged into the wall. Your symptoms sound like it's not getting any power. Sometimes when the charger clicks on, the ammeter might bounce a little as you described. If it's actually turning on and humming, but you're not getting any reading on the ammeter you've either got a bad OBC or the ammeter may be bad on the charger. Check the battery voltage with a multimeter, plug in the charger, and see if the voltage rises. This will tell you if it's charging or not.
TahoeDawgZ71 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-05-2012, 02:23 PM   #22
Not Yet Wild
 
Join Date: Sep 2010
Posts: 49
Default Re: 2007 Precedent not charging...

Actually that`s one of the things I checked first...I have a small battery tender plugged into the other part of the outlet for my Kawasaki Mule and it`s working fine , so i reversed the two with the same results.

Thanks for the tip though! I normally try the simple things first , but this time it wasn`t so simple
redberanclubcar is offline   Reply With Quote
Unread 08-05-2012, 05:34 PM   #23
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,962
Default Re: 2007 Precedent not charging...

There is an internal fuse in the charger as well. Is it blown?
TahoeDawgZ71 is offline   Reply With Quote
Unread 08-05-2012, 06:10 PM   #24
Not Yet Wild
 
Join Date: Sep 2010
Posts: 49
Default Re: 2007 Precedent not charging...

Good question...I was unaware of that..I will go check.

Thanks again!
redberanclubcar is offline   Reply With Quote
Unread 08-05-2012, 06:22 PM   #25
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,962
Default Re: 2007 Precedent not charging...

Follow the black wire out of the DC cord, it bolts up to the fuse. The other side of the fuse runs to the rectifier.
TahoeDawgZ71 is offline   Reply With Quote
Unread 08-05-2012, 06:41 PM   #26
Not Yet Wild
 
Join Date: Sep 2010
Posts: 49
Default Re: 2007 Precedent not charging...

Found it...never even noticed it was there! THAT was IT! YOU sir are THE man!

I can`t believe I never read of the same problem in all of my searching. It`s always rectifier this , obc that..etc... like I said I always try the obvious stuff first , but this one slipped by me. The glass was all white and I couldn`t see the fuse untill I removed the cover. It looks as though the connection at one terminal came loose where it was soldered to the nut. I just joined the two together for now to see if it worked..and it DID!

Thanks a million...now tomorrow I need to get a new fuse...what amp fuse is it?
redberanclubcar is offline   Reply With Quote
Unread 08-05-2012, 06:58 PM   #27
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: 2007 Precedent not charging...

Quote:
Originally Posted by redberanclubcar View Post
Found it...never even noticed it was there! THAT was IT! YOU sir are THE man!

I can`t believe I never read of the same problem in all of my searching. It`s always rectifier this , obc that..etc... like I said I always try the obvious stuff first , but this one slipped by me. The glass was all white and I couldn`t see the fuse untill I removed the cover. It looks as though the connection at one terminal came loose where it was soldered to the nut. I just joined the two together for now to see if it worked..and it DID!

Thanks a million...now tomorrow I need to get a new fuse...what amp fuse is it?
Glad you found the issue and hopefully thats all it is... Most of the charger related problems are the rectifier, breaker and relay..
erict is offline   Reply With Quote
Unread 08-05-2012, 07:26 PM   #28
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 2007 Precedent not charging...

Quote:
Originally Posted by redberanclubcar View Post
Found it...never even noticed it was there! THAT was IT! YOU sir are THE man!

I can`t believe I never read of the same problem in all of my searching. It`s always rectifier this , obc that..etc... like I said I always try the obvious stuff first , but this one slipped by me. The glass was all white and I couldn`t see the fuse untill I removed the cover. It looks as though the connection at one terminal came loose where it was soldered to the nut. I just joined the two together for now to see if it worked..and it DID!

Thanks a million...now tomorrow I need to get a new fuse...what amp fuse is it?
well in 11 years thats a 1st for me i have never eveer seen that fuse go bad........go figure just goes to show no matter how long youplay with these things you learn something new all the time.......david thats why your my here but what dosn,t make sense is the charger woking fine before hand that has me scratching....................................
shadowman is offline   Reply With Quote
Unread 08-05-2012, 09:18 PM   #29
Not Yet Wild
 
Join Date: Sep 2010
Posts: 49
Default Re: 2007 Precedent not charging...

I have the charger sitting on a small piece of 2X4 to keep it off the ground because sometimes if it rains just right there ends up being a small amt. of water on the floor in the garage and I didn`t want it to find it`s way to that area and get it wet.

I think it`s possible "someone" has knocked it off a time or two and that caused the weak solder joint to break loose , as the fuse wasn`t burned out , just broke free from one end...so it wasn`t REALLY a bad fuse as much as it was a broken solder joint.

Does anyone know where I can get a replacement fuse? I will do some searching but just thought I`d ask here first.

Thanks again for every ones help.
redberanclubcar is offline   Reply With Quote
Unread 08-05-2012, 09:26 PM   #30
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: 2007 Precedent not charging...

Quote:
Originally Posted by redberanclubcar View Post
I have the charger sitting on a small piece of 2X4 to keep it off the ground because sometimes if it rains just right there ends up being a small amt. of water on the floor in the garage and I didn`t want it to find it`s way to that area and get it wet.

I think it`s possible "someone" has knocked it off a time or two and that caused the weak solder joint to break loose , as the fuse wasn`t burned out , just broke free from one end...so it wasn`t REALLY a bad fuse as much as it was a broken solder joint.

Does anyone know where I can get a replacement fuse? I will do some searching but just thought I`d ask here first.

Thanks again for every ones help.
Never seen the fuse before so I'm not sure. Maybe radio shack?
erict is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2007 Precedent not charging Gas Club Car
Club Car 2007 IQ Battery Charging Solution Electric Club Car
2007 Precedent Electric Club Car
2007 Precedent vs DS Electric Club Car
2007 Club Car Precedent Golf Carts and Parts


All times are GMT -5. The time now is 09:51 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.