lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-02-2012, 04:48 PM   #1
Not Yet Wild
 
Join Date: Sep 2010
Posts: 49
Default 2007 Precedent not charging...

Hey guys , I`ll try to make this as short as possible..

Cart is a 2007 Prec. w/4 12 volt trojans that I put in in may 2011. everything was fine till just recently.

I noticed when i went out in the morning the cart was still charging...something it rarely does , and when you unplugged it the yellow light would flash indicating it`s not fully charged. So after our typical trip around the yard and neighborhood , it gets plugged back in for the night and the charger would kick on and the needle would go over to the right then slowly drop.

After a few days I`ve now noticed the needle no longer moves and the batteries are not charging. They are full of water, I replaced the three things on the charger , and man. charged each battery hoping to give them enough of a charge for the cart to start charging them in the event they were just too low...still nothing.

I`m going to load test the batteries tonight and re set the obc and see if that does anything..any other ideas?
redberanclubcar is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-02-2012, 06:24 PM   #2
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: 2007 Precedent not charging...

Quote:
Originally Posted by redberanclubcar View Post
Hey guys , I`ll try to make this as short as possible..

Cart is a 2007 Prec. w/4 12 volt trojans that I put in in may 2011. everything was fine till just recently.

I noticed when i went out in the morning the cart was still charging...something it rarely does , and when you unplugged it the yellow light would flash indicating it`s not fully charged. So after our typical trip around the yard and neighborhood , it gets plugged back in for the night and the charger would kick on and the needle would go over to the right then slowly drop.

After a few days I`ve now noticed the needle no longer moves and the batteries are not charging. They are full of water, I replaced the three things on the charger , and man. charged each battery hoping to give them enough of a charge for the cart to start charging them in the event they were just too low...still nothing.

I`m going to load test the batteries tonight and re set the obc and see if that does anything..any other ideas?
I forgot the correct procedure but I would try bypassing your OBC and see if the charger works.
erict is offline   Reply With Quote
Unread 08-02-2012, 07:51 PM   #3
Not Yet Wild
 
Join Date: Sep 2010
Posts: 49
Default Re: 2007 Precedent not charging...

The charger clicks and acts like it`s coming on and the needle jumps ever so slightly...

Thanks , I will look that up and give it a try.

I just load tested the batteries and they checked out ok.
redberanclubcar is offline   Reply With Quote
Unread 08-02-2012, 07:58 PM   #4
Not Yet Wild
Club Car
 
Join Date: Jul 2012
Location: Powdersville sc
Posts: 24
Default Re: 2007 Precedent not charging...

Mine had those exact same symptoms and it ended up being the rectifier in the charger.
tratt is offline   Reply With Quote
Unread 08-02-2012, 08:03 PM   #5
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 2007 Precedent not charging...

if batteries are ok and cable/wires are good on cart one would have to suspect OBC ..........if you can get a good charger just to try and confirm that would help.............................................. .......
shadowman is offline   Reply With Quote
Unread 08-02-2012, 08:04 PM   #6
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: 2007 Precedent not charging...

Quote:
Originally Posted by tratt View Post
Mine had those exact same symptoms and it ended up being the rectifier in the charger.
I think he did that already as his post says he replaced three items so I'm assuming he replaced the rectifier, relay, and breaker.
erict is offline   Reply With Quote
Unread 08-02-2012, 08:58 PM   #7
Not Yet Wild
Club Car
 
Join Date: Jul 2012
Location: Powdersville sc
Posts: 24
Default Re: 2007 Precedent not charging...

Quote:
Originally Posted by erict View Post
I think he did that already as his post says he replaced three items so I'm assuming he replaced the rectifier, relay, and breaker.
Sorry I missed that. I may have not understood what he was referring to. I'm not a cart expert, just offering what happened to me.
tratt is offline   Reply With Quote
Unread 08-02-2012, 09:02 PM   #8
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: 2007 Precedent not charging...

Quote:
Originally Posted by tratt View Post
Sorry I missed that. I may have not understood what he was referring to. I'm not a cart expert, just offering what happened to me.
I'm only assuming and he will have to confirm...
erict is offline   Reply With Quote
Unread 08-02-2012, 09:14 PM   #9
Not Yet Wild
 
Join Date: Sep 2010
Posts: 49
Default Re: 2007 Precedent not charging...

Correct...I couldn`t think of what the three things were called , but those are indeed the three items..same issue.

I tried re setting the obc...still nothing.

I`m taking the charger to my local cart shop tomorrow and see if there`s anyway to test it on a different cart...I almost think it HAS to be a charger issue , but who knows?

Thanks for the help guys , and if anyone else has any ideas , I`m open for suggestions.
redberanclubcar is offline   Reply With Quote
Unread 08-02-2012, 09:16 PM   #10
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: 2007 Precedent not charging...

Quote:
Originally Posted by redberanclubcar View Post
Correct...I couldn`t think of what the three things were called , but those are indeed the three items..same issue.

I tried re setting the obc...still nothing.

I`m taking the charger to my local cart shop tomorrow and see if there`s anyway to test it on a different cart...I almost think it HAS to be a charger issue , but who knows?

Thanks for the help guys , and if anyone else has any ideas , I`m open for suggestions.
At this point I would say it's your OBC. You need to bypass it and see if the charger works.
erict is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2007 Precedent not charging Gas Club Car
Club Car 2007 IQ Battery Charging Solution Electric Club Car
2007 Precedent Electric Club Car
2007 Precedent vs DS Electric Club Car
2007 Club Car Precedent Golf Carts and Parts


All times are GMT -5. The time now is 09:16 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.