lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-04-2012, 01:32 PM   #1
Not Yet Wild
 
Join Date: Aug 2012
Posts: 5
Default SLOW! running 1/2 speed fwd & 1/4 speed rev

I have a 1996 Club Car Series 48 volt, It is running very slow in forward or just shuts off. Replaced controller, micro switches (on f & R Handle), tightened & checked F & R switch, has one of the old style black pot. box (to the left side of pedal). The batteries are about 5 yrs old, but do fully charge to 8 volts (shuts off charger). The batteries drop to about 7.6 volts if holding brake and gas to give a slight load. Any help if possible?? Can I check Pot. box with ohm meter?? Thanks Tom
1laptech is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-04-2012, 10:35 PM   #2
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,869
Default Re: SLOW! running 1/2 speed fwd & 1/4 speed rev

You can adjust the pot box, so maybe it is out of adjustment?
jakesnake27 is offline   Reply With Quote
Unread 08-04-2012, 11:39 PM   #3
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,966
Default Re: SLOW! running 1/2 speed fwd & 1/4 speed rev

Pull the Green, Black, and White wires off of the rear-most micro switch behind the F&R switch. Make a jumper wire, or just use a small blade fuse to jump the Green and White together, and just let the black hang free. This will bypass the resistor that makes the car run half speed in reverse. See if this makes any difference with your issue.
TahoeDawgZ71 is offline   Reply With Quote
Unread 08-06-2012, 01:41 AM   #4
Not Yet Wild
 
Join Date: Aug 2012
Posts: 5
Default Re: SLOW! running 1/2 speed fwd & 1/4 speed rev

Ok, I pulled the batteries after using a Club car Load tester, they were marginal. after removing all the batteries I noticed the plastic connector from the pot box had heavy corrosion ate into the wires. Cut back wires re-spliced and the cart is working great. Thanks for the input.
Tom
1laptech is offline   Reply With Quote
Unread 10-22-2013, 06:16 AM   #5
Gone Wild
 
Join Date: Dec 2010
Posts: 352
Default Re: SLOW! running 1/2 speed fwd & 1/4 speed rev

good to know
kantuckian is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
1981 club car slow speed fast speed Electric Club Car
97 CC slow speed. Electric Club Car
g8 one speed SLOW! Electric Yamaha
slow speed only!!!! Electric EZGO
Slow Speed Electric EZGO


All times are GMT -5. The time now is 01:06 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.