lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-06-2012, 09:41 PM   #1
Not Yet Wild
 
Cajun TBoy's Avatar
Club Car
 
Join Date: Jan 2012
Location: Church Point, LA
Posts: 23
Default speed sensor

I have been reading about how to check them. I gps'd cart and was 17mph but I can push cart freely, should I be concerned orforget about it. I have the rear buzzer disconected would that effect it any?
Next question is about the battery cable going through the obc, If replacing cable does it have to go back through hole? Cable is larger than hole. Oh cart is a 05 Precedent. When I purchased it I was told it was an 08. Thanks
Cajun TBoy is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-07-2012, 07:40 AM   #2
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: speed sensor

Quote:
Originally Posted by Cajun TBoy View Post
I have been reading about how to check them. I gps'd cart and was 17mph but I can push cart freely, should I be concerned orforget about it. I have the rear buzzer disconected would that effect it any?
Next question is about the battery cable going through the obc, If replacing cable does it have to go back through hole? Cable is larger than hole. Oh cart is a 05 Precedent. When I purchased it I was told it was an 08. Thanks
I wouldn't worry about the your speed sensor as you will know when it's bad because your cart will run slow. You can still push the cart freely but there will be some resistance when doing it. The battery cable must run through your OBC to charge correctly and you can call Scotty and see if he has any stud kits left. Here is the stud kit.

http://www.cartsunlimited.net/Batter..._Upgrades.html
erict is offline   Reply With Quote
Unread 08-07-2012, 09:30 AM   #3
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: speed sensor

Quote:
Originally Posted by Cajun TBoy View Post
I have been reading about how to check them. I gps'd cart and was 17mph but I can push cart freely, should I be concerned orforget about it. I have the rear buzzer disconected would that effect it any?
Next question is about the battery cable going through the obc, If replacing cable does it have to go back through hole? Cable is larger than hole. Oh cart is a 05 Precedent. When I purchased it I was told it was an 08. Thanks
yes cable has to be thur hole in OBC they make a kit to solve that issue now..........................................
shadowman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
MCOR? Speed Sensor? Controller? Cart Runs at half speed. Advice, please. Electric Club Car
08 precedent electric speed sensor problem. Cart starts at proper speed then slows . Electric Club Car
Half speed, speed sensor problem?. Electric Club Car
Speed Sensor Electric Club Car
speed sensor Electric EZGO


All times are GMT -5. The time now is 08:24 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.