lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-10-2012, 03:30 PM   #1
Not Yet Wild
 
Join Date: Nov 2011
Posts: 12
Default Club Car Not Charging after recent changes

I recently added a plum quick motor, HD f/r switch and 2 guage wiring. Now when I plug the charger in, it will kick on and then shut off after a few minutes. When I plug it in it jumps up to around 19 amps and then when it shuts off the battery light comes on on the cart. The light will come on for a bout five seconds then go off and does this repeatedly. I went through the procedure to reset the OBC, skipping the tow run switch step because I have a series cart. Any thoughts on what problem this could be?
Indyirishfan is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-10-2012, 04:52 PM   #2
Not Yet Wild
Club Car
 
Join Date: Jul 2012
Location: Powdersville sc
Posts: 24
Default Re: Club Car Not Charging after recent changes

Did you run you negative wire from battery 4 through the obc?
tratt is offline   Reply With Quote
Unread 08-10-2012, 05:25 PM   #3
Not Yet Wild
 
Join Date: Nov 2011
Posts: 12
Default Re: Club Car Not Charging after recent changes

[QUOTE=tratt;761198]Did you run you negative wire from battery 4 through the obc?[/QUOT

Oops. Any ideas on how to get that two guage wire throught there?
Indyirishfan is offline   Reply With Quote
Unread 08-10-2012, 06:36 PM   #4
Not Yet Wild
Club Car
 
Join Date: Jul 2012
Location: Powdersville sc
Posts: 24
Default Re: Club Car Not Charging after recent changes

There is a kit you can order but I made one from a piece of 5/16 stainless threaded rod, a couple of rubber washers and four stainless nuts. Just dont tighten down too much onto OBC.
tratt is offline   Reply With Quote
Unread 08-10-2012, 08:01 PM   #5
Not Yet Wild
 
Join Date: Nov 2011
Posts: 12
Default Re: Club Car Not Charging after recent changes

Quote:
Originally Posted by tratt View Post
Did you run you negative wire from battery 4 through the obc?
I guess I am a little confused. When I took the old cables out, the negative wire ran from the last battery from the positive side through a slot in the OBC. It wasn't connected to anything on the OBC it was just fed through there. If it can get the new negative wire back through there is that all I need to do. The way it was fed through there it didn't look like it did anything except hold the wire in place.
Indyirishfan is offline   Reply With Quote
Unread 08-10-2012, 08:21 PM   #6
Not Yet Wild
Club Car
 
Join Date: Jul 2012
Location: Powdersville sc
Posts: 24
Default Re: Club Car Not Charging after recent changes

No, that is an ammeter similar to the handheld clamp on meters you can buy for testing. It measures the amps being used by the cart between charges and computes the proper recharge for it. I have read on other forum that some have had success drilling the plastic housing out to a larger diameter but I wouldn't advise that. If you nick the copper coil that is encased in there it will not function. What I did was use the threaded rod to pass through the OBC and connected to that on each side with lugs and nuts. I used fender washers and rubber washers to pad the plastic housing from the lugs and nuts .
tratt is offline   Reply With Quote
Unread 08-10-2012, 08:38 PM   #7
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Club Car Not Charging after recent changes

talk to scotty i think he has a kit but your wire has to go thur OBC theres a sensor so to speak in there and then it bolts to B- on controller..........or you can get the 6 gage wire run it thur and hook it up with the new 2 gage but your better off the other way..............................................8 )
shadowman is offline   Reply With Quote
Unread 08-10-2012, 08:49 PM   #8
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: Club Car Not Charging after recent changes

Here is Scotty's kit.

b9ef18bc4788bae0aa1c67c97391514b.jpg
erict is offline   Reply With Quote
Unread 08-10-2012, 10:22 PM   #9
Not Yet Wild
 
Join Date: Nov 2011
Posts: 12
Default Re: Club Car Not Charging after recent changes

I was able to cut the lug off and feed the wire through and reconnect with a new lug. It seems to be working now. Thanks for the help.
Indyirishfan is offline   Reply With Quote
Unread 08-11-2012, 11:15 AM   #10
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,966
Default Re: Club Car Not Charging after recent changes

Quote:
Originally Posted by Indyirishfan View Post
I guess I am a little confused. When I took the old cables out, the negative wire ran from the last battery from the positive side through a slot in the OBC.
This is wrong. It should hook up to the negative post of the last battery.
TahoeDawgZ71 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
99 Club Car Not Charging Electric Club Car
club car charging Electric Club Car
Most Recent Build Rizla Race Replica Side x Sides-ATV-Quads-Bikes-Jeeps-4x4's!
Recent additions Electric EZGO
charging outside of the club car? Electric Club Car


All times are GMT -5. The time now is 03:04 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.