lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-12-2012, 10:40 PM   #1
Not Yet Wild
 
Join Date: Aug 2012
Posts: 2
Default 2006 club car starting problem.

We just bought a 2006 club car 48v electric golf cart. Ran fine when we bought it and also when we dropped it off to the campground an hour later. When we went camping the next weekend, it now has issues. When you turn it on the beeper sounds in f and r and the solenoid is not engaging. However sometimes it would still work. While checking it out I crossed something 2 electrical posts on the bottom of the motor. And now the diode is burning up. And also now when I turn it to tow it doesn't cut the electrical. I am completely lost now.
kevinw is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-13-2012, 07:44 AM   #2
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: 2006 club car starting problem.

. . . if you shorted out the motor posts, you may have destroyed your controller . . . wait for TahoeDawg or ScottyB to read this thread . . .
Stevegrmich is offline   Reply With Quote
Unread 08-13-2012, 08:46 AM   #3
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 2006 club car starting problem.

Quote:
Originally Posted by kevinw View Post
We just bought a 2006 club car 48v electric golf cart. Ran fine when we bought it and also when we dropped it off to the campground an hour later. When we went camping the next weekend, it now has issues. When you turn it on the beeper sounds in f and r and the solenoid is not engaging. However sometimes it would still work. While checking it out I crossed something 2 electrical posts on the bottom of the motor. And now the diode is burning up. And also now when I turn it to tow it doesn't cut the electrical. I am completely lost now.
real good chance you may have took out controller and possible a few other things...................please don,t take this personal as its not meant to be at all but at this point you might want to consider taking it to a shop or having someone come to your campground to look at it...............this happens alot someone wants to work on their cart themselves to save a few bucks and i completely understand that but in the process you turn a 50 dollar problem into a 500 dollar problem...........i see this at the campground i belong to almost every weekend, they pull the cart to my place and tell me the story but by then its to late damage done.................good luck with itkeep your fingers crossed.................................
shadowman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2006 Club Car Drum problem..UPDATE Electric Club Car
1992 Club Car starting problem Gas Club Car
2006 48v electric club car charging problem Electric Club Car
97 Gas Club Car Starting/RPM? Problem Gas Club Car
93 club car gas, minor starting problem Gas Club Car


All times are GMT -5. The time now is 04:23 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.