lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-19-2012, 12:40 PM   #1
Gone Wild
 
cheapjeep2's Avatar
Club Car
 
Join Date: Nov 2008
Location: Peachtree City, Georgia
Posts: 1,529
Default Does this sound like a speed senor?

The cart is a DS IQ cart with a plumquick motor and a stock controller. Here is the symptom: had it out for a couple of hours last night and were cruising along when it almost felt like a downshift in a car, now it is extremely slow in forward, but seems ok in reverse. Going forward it starts to accelerate, but then backs off and won't go any faster.

Does this sound like a speed sensor on the motor?
cheapjeep2 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-19-2012, 01:30 PM   #2
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: Does this sound like a speed senor?

Quote:
Originally Posted by cheapjeep2 View Post
The cart is a DS IQ cart with a plumquick motor and a stock controller. Here is the symptom: had it out for a couple of hours last night and were cruising along when it almost felt like a downshift in a car, now it is extremely slow in forward, but seems ok in reverse. Going forward it starts to accelerate, but then backs off and won't go any faster.

Does this sound like a speed sensor on the motor?
Sounds like speed sensor to me.
erict is offline   Reply With Quote
Unread 08-19-2012, 01:59 PM   #3
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Does this sound like a speed senor?

sounds like it went into limp mode......speed sensor..........................
shadowman is offline   Reply With Quote
Unread 08-19-2012, 03:36 PM   #4
Gone Wild
 
cheapjeep2's Avatar
Club Car
 
Join Date: Nov 2008
Location: Peachtree City, Georgia
Posts: 1,529
Default Re: Does this sound like a speed senor?

So the next question is, sense this is a PlumQuick modified motor do I need to get the sensor from them?
cheapjeep2 is offline   Reply With Quote
Unread 08-19-2012, 03:46 PM   #5
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: Does this sound like a speed senor?

Quote:
Originally Posted by cheapjeep2 View Post
So the next question is, sense this is a PlumQuick modified motor do I need to get the sensor from them?
I would so you get the exact replacement.
erict is offline   Reply With Quote
Unread 08-19-2012, 04:20 PM   #6
Gone Wild
 
cheapjeep2's Avatar
Club Car
 
Join Date: Nov 2008
Location: Peachtree City, Georgia
Posts: 1,529
Default Re: Does this sound like a speed senor?

Found it, broken magnet.
cheapjeep2 is offline   Reply With Quote
Unread 08-19-2012, 04:41 PM   #7
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: Does this sound like a speed senor?

Quote:
Originally Posted by cheapjeep2 View Post
Found it, broken magnet.
Speed sensor magnet?
erict is offline   Reply With Quote
Unread 08-19-2012, 04:51 PM   #8
Gone Wild
 
cheapjeep2's Avatar
Club Car
 
Join Date: Nov 2008
Location: Peachtree City, Georgia
Posts: 1,529
Default Re: Does this sound like a speed senor?

Quote:
Originally Posted by erict View Post
Speed sensor magnet?
Yep, so I will need to get a replacement from PlumQuick as they put a different magnet on to fool the sensor.
cheapjeep2 is offline   Reply With Quote
Unread 08-19-2012, 04:56 PM   #9
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: Does this sound like a speed senor?

Quote:
Originally Posted by cheapjeep2 View Post
Yep, so I will need to get a replacement from PlumQuick as they put a different magnet on to fool the sensor.
Correct...
erict is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Sound Electric EZGO
sound Lifted Golf Carts
Sound right? Electric EZGO
got sound but no go Gas Yamaha
PDS speed senor placement Electric EZGO


All times are GMT -5. The time now is 08:16 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.