lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-22-2012, 09:07 PM   #1
Not Yet Wild
 
Join Date: Jun 2012
Posts: 4
Default Selenoid and Resistor hot and not charging

I put new batterys in this old 36 Volt Club Car and it works. I've had the charge checked out and it works. However, when I plug it into the Cart, it doesn't appear to be charging. The fuse on the cart isn't bad (doesn't look that way) and I've checked the wiring diagram. Appears to be correct.

Also, (my son uses it to carry yard mowing equipment and it's NOT used much) he has come home twice and told me he smelled something burning. First time I couldn't smell anything, last night I could. I tried to sniff it out and feel cables for heat and didn't really feel anything until I touched the aluminum cross frame that is over the selnoid and resistors.

So, what is wrong? Are the two related? Thanks, 1st post.
RDPJDP94 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-22-2012, 10:29 PM   #2
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,042
Default Re: Selenoid and Resistor hot and not charging

The resistor do make a bit of heat. They burn off amperage not used. The slower you go the more they waste (burn off). Tell your son to speed up to cool things down....


And welcome to BGW!
scottyb is offline   Reply With Quote
Unread 08-23-2012, 11:35 AM   #3
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Selenoid and Resistor hot and not charging

Quote:
Originally Posted by scottyb View Post
The resistor do make a bit of heat. They burn off amperage not used. The slower you go the more they waste (burn off). Tell your son to speed up to cool things down....


And welcome to BGW!
scotty is right on.......if your not driving pedal to floor it makes heat and the resistor coils job is to disapate that heat so it sounds like things are working.......you can take that cover off and make sure all coils are in good shape and no breaks or touching each other........................................
shadowman is offline   Reply With Quote
Reply

Tags
36 volt club car
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
selenoid clicks, no movement Electric EZGO
keeps burning up first selenoid Electric Club Car
Replace starter selenoid - generic ok? Gas EZGO
selenoid troble Electric Club Car
1989 Club Car Resistor Cart Not Charging Electric Club Car


All times are GMT -5. The time now is 08:56 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.