lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-01-2012, 11:15 AM   #1
Not Yet Wild
 
Laser's Avatar
Club Car
 
Join Date: Aug 2012
Location: Louisville, KY
Posts: 25
Default Brake adjustment?

I installed a 4" lift kit on a 2007 CC. The rear leaf spring is now above the axle instead of below it. When braking now at slow speeds, it feels like there are no brakes at all, then the pedal pops up under your foot and the brakes lock up. They lock up to the point where the tires will screech. Also, there is now not enough holding power to keep the cart still when you lock down the brake pedal. Did I cause this with the lift kit installation? Is this as simple as an adjustment? If so, I assume the floor mat pulls up all the way around and the adjustment cable is beneath. Anyone with a similar experience or who knows what's going on, please chime in.
Laser is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-01-2012, 11:18 AM   #2
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: Brake adjustment?

Quote:
Originally Posted by Laser View Post
I installed a 4" lift kit on a 2007 CC. The rear leaf spring is now above the axle instead of below it. When braking now at slow speeds, it feels like there are no brakes at all, then the pedal pops up under your foot and the brakes lock up. They lock up to the point where the tires will screech. Also, there is now not enough holding power to keep the cart still when you lock down the brake pedal. Did I cause this with the lift kit installation? Is this as simple as an adjustment? If so, I assume the floor mat pulls up all the way around and the adjustment cable is beneath. Anyone with a similar experience or who knows what's going on, please chime in.
Replace your left brake cable with a right brake cable which is longer. Common fix when adding lift kits..
erict is offline   Reply With Quote
Unread 09-01-2012, 11:32 AM   #3
Not Yet Wild
 
Laser's Avatar
Club Car
 
Join Date: Aug 2012
Location: Louisville, KY
Posts: 25
Default Re: Brake adjustment?

The things you learn... Thanks!
Laser is offline   Reply With Quote
Unread 09-02-2012, 11:27 AM   #4
Not Yet Wild
 
Laser's Avatar
Club Car
 
Join Date: Aug 2012
Location: Louisville, KY
Posts: 25
Default Re: Brake adjustment?

Follow up: I pulled the floor panel and checked the brake linkage. It was very loose, so it didn't look like the addition of a lift kit put any stretch on the cables. In fact, I tightened it up a bit to take some of the slack out, but the brakes still don't engage at first, then the pedal jumps up and the rear wheels lock up. I'm installing Ausco mechanical disc brakes anyway so I'll do that and see if the problem persists.
Laser is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
precedent brake adjustment Electric Club Car
brake adjustment Electric EZGO
04' ST 350 brake adjustment Gas EZGO
EZ-GO brake adjustment Electric EZGO
brake adjustment Electric Club Car


All times are GMT -5. The time now is 08:28 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.