lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-16-2012, 05:08 AM   #11
Not Yet Wild
 
Iannacar's Avatar
 
Join Date: Nov 2012
Location: Los angles
Posts: 1
Default Re: 2005 club car 48v limo, loss of acceleration

I think so you should take it to the expert mechanic or to companies servicing center. My car was also giving such type of a problem, so my mechanic told to change the speed sensor and know it is working properly.
Iannacar is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-17-2012, 01:05 PM   #12
Not Yet Wild
Club Car
 
Join Date: Mar 2009
Location: Northern Wisconsin
Posts: 48
Default Re: 2005 club car 48v limo, loss of acceleration

Can you tell me what the MCOR is and its location. I have a 2005 Precedent and every once in a while it just won't go. Push the pedal a couple of times and it takes off. Been doing this for some time. Thanks
sb2bb is offline   Reply With Quote
Unread 11-17-2012, 03:53 PM   #13
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: 2005 club car 48v limo, loss of acceleration

Quote:
Originally Posted by sb2bb View Post
Can you tell me what the MCOR is and its location. I have a 2005 Precedent and every once in a while it just won't go. Push the pedal a couple of times and it takes off. Been doing this for some time. Thanks
. . . see detail 18, page 4-12, here:

2005 Precedent IPL


. . .
Stevegrmich is offline   Reply With Quote
Unread 11-17-2012, 08:39 PM   #14
Not Yet Wild
Club Car
 
Join Date: Mar 2009
Location: Northern Wisconsin
Posts: 48
Default Re: 2005 club car 48v limo, loss of acceleration

Thanks Steve, I just ordered one online, I'm sure this is my problem, "I hope".
sb2bb is offline   Reply With Quote
Unread 11-18-2012, 07:35 AM   #15
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: 2005 club car 48v limo, loss of acceleration

Quote:
Originally Posted by sb2bb View Post
Thanks Steve, I just ordered one online, I'm sure this is my problem, "I hope".
. . . good luck . . .
Stevegrmich is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
1997 Club Car limo DS 11hp sputters on acceleration Gas Club Car
'83 club car acceleration problem Electric Club Car
Loss of speed on 2005 EZGO PDS 36V cart Electric EZGO
Yami G1 loss of power and acceleration? Gas Yamaha
2005 TXT "stumbles" on acceleration Gas EZGO


All times are GMT -5. The time now is 10:06 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.