lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-05-2012, 04:52 PM   #1
Not Yet Wild
Club Car
 
Join Date: Dec 2011
Location: SoCal desert
Posts: 13
Default Cleaned Batteries and cables/now cart won't run

I cleaned the battery posts and cables today with baking soda and water. The cart is a 2002 48 volt Club Car with new Trojan batteries. After cleaning the corrosion and washing and drying the batteries and connections the cart would not move in reverse. All lights,horn, etc are working. When I got into the cart after cleanup to back up, no reverse, however forward was still working so I drove the cart into the garage. I shifted into reverse, still nothing. Then forward would not work either. I re-checked all connections and can't find anything wrong. Anybody got any suggestions.
Rockman59 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-05-2012, 05:28 PM   #2
Gone Wild
 
lmswest's Avatar
 
Join Date: Jul 2012
Posts: 366
Default Re: Cleaned Batteries and cables/now cart won't run

Prob got the f& r switch wet. I did the same thing when I first got mine. Take a leaf blower and blow out even connection then spray liberally with wd 40. It was actually designed to displace water..
lmswest is offline   Reply With Quote
Unread 09-05-2012, 10:12 PM   #3
Not Yet Wild
Club Car
 
Join Date: Dec 2011
Location: SoCal desert
Posts: 13
Default Re: Cleaned Batteries and cables/now cart won't run

I took your advice and cleaned the forward/reverse switch and adjusted the three prongs that make contact to deliver the power. Problem solved. Cart is running great again.
Rockman59 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
New Batteries and Cables Electric EZGO
Removed & cleaned batteries, now won't go? Electric Club Car
New batteries, new cables, Electric EZGO
Cleaned Batteries - Cart does not work Electric EZGO
Cables batteries etc Electric EZGO


All times are GMT -5. The time now is 05:32 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.