lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-09-2012, 08:55 PM   #1
Not Yet Wild
 
79 caroche's Avatar
Club Car
 
Join Date: Aug 2009
Location: Michigan
Posts: 74
Default I really need help!

I know this isnt the yamaha board but nobody has replyed to me there so i figured i should ask you guys because you have never let me down! Thanks for that by the way!! So i got a g2 yamaha golf cart im **** sure its wired right and has a new solenoid when you hit the pedal theres nothing not even a click.
Any ideas as to whats wrong?
79 caroche is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-10-2012, 02:00 AM   #2
Gone Wild
 
Scott H.'s Avatar
Club Car
 
Join Date: May 2011
Location: Charleston, South Carolina
Posts: 672
Default Re: I really need help!

You sure the key switch is good?

-Scott H.
Scott H. is offline   Reply With Quote
Unread 09-10-2012, 08:08 PM   #3
Not Yet Wild
 
79 caroche's Avatar
Club Car
 
Join Date: Aug 2009
Location: Michigan
Posts: 74
Default Re: I really need help!

Yep its fine
79 caroche is offline   Reply With Quote
Unread 09-10-2012, 08:10 PM   #4
Not Yet Wild
 
79 caroche's Avatar
Club Car
 
Join Date: Aug 2009
Location: Michigan
Posts: 74
Default Re: I really need help!

When u cross the big terminals on solinoid it runs? I dont get it lol
79 caroche is offline   Reply With Quote
Unread 09-10-2012, 08:56 PM   #5
Gone Wild
 
Join Date: Jul 2012
Posts: 912
Default Re: I really need help!

Do you have a diode on the small posts? Is it in the right direction?
Speedchaser is offline   Reply With Quote
Unread 09-10-2012, 09:01 PM   #6
Not Yet Wild
 
79 caroche's Avatar
Club Car
 
Join Date: Aug 2009
Location: Michigan
Posts: 74
Default Re: I really need help!

Nope no diode that i can see, when you cross the main terminals the cart will start to move without having the pedal depressed
79 caroche is offline   Reply With Quote
Unread 09-10-2012, 10:58 PM   #7
Not Yet Wild
 
79 caroche's Avatar
Club Car
 
Join Date: Aug 2009
Location: Michigan
Posts: 74
Default Re: I really need help!

Well i fixed it in my own way for some reason the key wasnt giving the solenoid power but it was wired exactly how it was supposed to be thats why i prefere club car and ezgo lol!! Thanks for your posts guys they really helped!
79 caroche is offline   Reply With Quote
Unread 09-13-2012, 03:27 PM   #8
Not Yet Wild
 
Join Date: Sep 2012
Posts: 1
Default Re: I really need help!

are you geyyin voltage to solonoid
ddubree is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes



All times are GMT -5. The time now is 03:33 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.