lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-20-2012, 03:14 PM   #1
Not Yet Wild
Club Car
 
Join Date: Sep 2009
Location: Murphy Texas
Posts: 14
Default 2002 DS running slow.

Hello Guys.
My cart was running perfect after new batts and new VGLIDE. I checked the water in batteries topped a few cells then rinsed off dust making sure not to get vglide we. No is runs real slow. Mine has the curly resistors and was wandering if they go bad? None are broken.
I have removed all cables cleaned post and term ends. All 6 Batts are 6.4 volts

Any ideals?
Thanks....
stubby1968 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-20-2012, 03:16 PM   #2
Gone Wild
 
camaroluvz28's Avatar
Yamaha
 
Join Date: Sep 2010
Location: Florida
Posts: 932
Default Re: 2002 DS running slow.

They dont really go bad unless burnt in half as they are only coils of steel...Sounds like something may have got wet that shouldn't have...I would let it dry out for a day or so and try again...
camaroluvz28 is offline   Reply With Quote
Unread 09-20-2012, 07:04 PM   #3
Gone Wild
 
lmswest's Avatar
 
Join Date: Jul 2012
Posts: 366
Default Re: 2002 DS running slow.

Or for faster results, try drying it out with a leaf blower then spray the connections down with wd-40.
lmswest is offline   Reply With Quote
Unread 09-21-2012, 07:00 PM   #4
Member #16,745
 
jakesnake27's Avatar
Harley Davidson
 
Join Date: Aug 2009
Location: Missouri
Posts: 9,866
Default Re: 2002 DS running slow.

I don't think it's an 02 if it has resistors. I think all carts were either solid state or IQ by then...
jakesnake27 is offline   Reply With Quote
Unread 09-21-2012, 10:31 PM   #5
Not Yet Wild
Club Car
 
Join Date: Sep 2009
Location: Murphy Texas
Posts: 14
Default Re: 2002 DS running slow.

That's what the tag said on the floor pan. And it has the black support struts and one piece seat back. It may have been a carry over from previous years.
I have had other people tell me that 02 did not have resistors also....
stubby1968 is offline   Reply With Quote
Unread 09-21-2012, 10:40 PM   #6
Not Yet Wild
Club Car
 
Join Date: Sep 2009
Location: Murphy Texas
Posts: 14
Default Re: 2002 DS running slow.

Took the seat off placed my shop fan on top for 3 hours yesterday. I have checked my charger its good. All the battery levels are good. Still kinda creeps will pull a hill slowly does not act like dead batteries.
What are the symptoms elect motor going bad? This was a cart used by a welder every day for years before I got it. Maybe its just wore out???
stubby1968 is offline   Reply With Quote
Unread 09-21-2012, 11:05 PM   #7
Not Yet Wild
Club Car
 
Join Date: Sep 2009
Location: Murphy Texas
Posts: 14
Default Re: 2002 DS running slow.

UPDATE...........Took cart out for ride this evening after with a full charge and my headlights were real dim...... My charger clicks on and runs for at least 2 hours then turns off. I checked batteries and all had 6.4
maybe my charger is not working correctly?
stubby1968 is offline   Reply With Quote
Unread 09-22-2012, 06:03 AM   #8
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: 2002 DS running slow.

Quote:
Originally Posted by jakesnake27 View Post
I don't think it's an 02 if it has resistors. I think all carts were either solid state or IQ by then...
. . . it's a 36v resistor cart . . .
Stevegrmich is offline   Reply With Quote
Unread 09-22-2012, 06:14 AM   #9
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: 2002 DS running slow.

Quote:
Originally Posted by stubby1968 View Post
UPDATE...........Took cart out for ride this evening after with a full charge and my headlights were real dim...... My charger clicks on and runs for at least 2 hours then turns off. I checked batteries and all had 6.4
maybe my charger is not working correctly?
. . . double check your wiring on battery pack to make sure you did not reconnect something wrong or left a wire dangling . . . the dim headlights does not sound right . . . assuming it is a 36v resistor cart, the 6.4v per battery sounds good . . . after charging, does entire pack voltage exceed 38v?

. . . dl a copy of this to your computer for reference:

2001-2002 CC DS IPL
Stevegrmich is offline   Reply With Quote
Unread 09-22-2012, 10:44 AM   #10
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 2002 DS running slow.

yeah those dim headlights are pointing to a possible battery or wiring problem......have you load tested the batteries? good voltage means nothing if they fail under load...................................
shadowman is offline   Reply With Quote
Reply

Tags
ds running slow
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2002 ezgo gas running hot Gas EZGO
2002 gas ds continues running Gas Club Car
2002 EZGO PDS slow Electric EZGO
2002 36v cc new batteries but very slow Electric Club Car
2002 Club car goes slow Electric Club Car


All times are GMT -5. The time now is 05:28 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.