lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-21-2012, 10:49 PM   #1
Not Yet Wild
Club Car
 
Join Date: Sep 2012
Posts: 6
Default cart dead

I have a 2006 Precedent.A week ago it ran great but today nothing. No backup buzzer in reverse , wont move, when i plug in charger nothing.PLEASE HELP!bad battery cable? bad obc? i have no idea!
dead precedent is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-22-2012, 03:37 AM   #2
Not Yet Wild
 
mkbrower's Avatar
Club Car
 
Join Date: Jun 2011
Location: cliffside NC
Posts: 55
Default Re: cart dead

I would start by checking battery voltage with a meter. You may have a dead battery. I believe if battery voltage gets too low it will not allow your charger to start. I'm not cart expert so I could be wrong. I'm still learning too.

Mark
mkbrower is offline   Reply With Quote
Unread 09-22-2012, 08:12 AM   #3
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: cart dead

Mark is correct. Start by checking battery voltage and post your readings.
erict is offline   Reply With Quote
Unread 09-22-2012, 10:41 AM   #4
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: cart dead

2006 does it have 12 volt batteries? yes check voltage and if needed you can use a 12 volt charger and charge each one ( no need to disconnect any cables ) after you charge each one then try your charger see if itworks.........................
shadowman is offline   Reply With Quote
Unread 09-22-2012, 11:15 AM   #5
Not Yet Wild
Club Car
 
Join Date: Sep 2012
Posts: 6
Default Re: cart dead

Thanks everyone i will check and charge this weekend and let you know what happens.
dead precedent is offline   Reply With Quote
Unread 09-22-2012, 05:48 PM   #6
Not Yet Wild
Club Car
 
Join Date: Sep 2012
Posts: 6
Default Re: cart dead

Ok i took my meter the two passenger side batteries i got 24.5 volts and 26.5 volts. The two driver side i got 0 volts on both.When i went from positive on driverside (where the charger cable hooks up) to the negative on the passenger side that runs to obc i got 49.5 volts.When i switched the cart to reverse sometimes the buzzer went off and sometimes it didnt.When i plug charger in it doesnt come on.What now??
dead precedent is offline   Reply With Quote
Unread 09-22-2012, 09:18 PM   #7
Getting Wild
 
JasonsGolfCarts's Avatar
Club Car
 
Join Date: Jun 2012
Location: Brooksville, FL
Posts: 108
Default Re: cart dead

You either have a bad battery or two or something drained those batteries. Do you have any accessories? (lights, stereo) If so, I am guessing they are hooked to the dead battery and now your charger does not recognize that it is hooked to the battery pack. I would recommend that you charge each battery independently with a standard 12 volt charger. You do not have to disconnect the batteries, just hook to the positive and negative of one battery with the charger. MAKE SURE THE CART IS IN TOW MODE WHEN YOU DO THIS IN CASE YOU HOOK IT UP WRONG. Once you have fully charged each battery individually, plug in your golf cart charger again and it should top off your pack. If this was the problem, you cart should run fine once you turn your tow / run switch back to run.
JasonsGolfCarts is offline   Reply With Quote
Unread 09-22-2012, 09:40 PM   #8
Gone Wild
 
delagem's Avatar
Club Car
 
Join Date: Feb 2011
Location: Homer, NY
Posts: 216
Default Re: cart dead

Quote:
Originally Posted by dead precedent View Post
Ok i took my meter the two passenger side batteries i got 24.5 volts and 26.5 volts. The two driver side i got 0 volts on both..... i got 49.5 volts.
You're measuring your voltage wrong. Unless you've got two 24v batteries?

Those numbers don't make sense.

Check each battery separately, from neg on one to the pos on just one battery at a time...

Post those numbers.
delagem is offline   Reply With Quote
Unread 09-23-2012, 12:20 PM   #9
Not Yet Wild
Club Car
 
Join Date: Sep 2012
Posts: 6
Default Re: cart dead

OK here's where I'm at. I have 4 12volt batteries.I hooked a charger to one a jumper box to another hooked cart charger and it came on and started charging so hopefully this does it. Delegam I did have meter set wrong thanks
dead precedent is offline   Reply With Quote
Unread 09-23-2012, 02:27 PM   #10
Not Yet Wild
Club Car
 
Join Date: Sep 2012
Posts: 6
Default Re: cart dead

After 3 hours of charging my cart is running!!The batteries arent fully charged yet so they must have been dead dead.
dead precedent is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Dead Cart Electric Club Car
dead cart Electric EZGO
Dead cart Electric Yamaha
Dead cart, possible dead Solenoid Electric Club Car


All times are GMT -5. The time now is 02:10 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.