lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-04-2012, 09:58 AM   #1
Not Yet Wild
 
Join Date: Oct 2012
Posts: 9
Default 2005 Precendent slows and intermittently stops

Hi all

I have a 2005 CC Precedent 48v, new batteries, MCOR replaced 1 year ago for different problem. The issue I am having now is when I am driving with the pedal in almost any depressed position the cart/motor will stop propelling the cart until I let the pedal up and push back down. I can do this repeatedly and it will continue on. Also, I noticed when I "floor it" it will start out very fast then immediately slow. If I let up on the pedal and floor it again, fast..then immediately slow. I first thought the MCOR again however as I said the one in there is only about a year old. I checked all the cable connections, none are loose. Any ideas?
dschron is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-04-2012, 10:07 AM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 2005 Precendent slows and intermittently stops

2005 are famus for speed sensors going bad, i would 1st look at speed sensor and 2nd back to the new m-cor.......year old dosn,t mean much these days......................
shadowman is offline   Reply With Quote
Unread 10-04-2012, 07:45 PM   #3
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: 2005 Precendent slows and intermittently stops

I would say it's a bad MCOR again.
erict is offline   Reply With Quote
Unread 10-04-2012, 10:01 PM   #4
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,009
Default Re: 2005 Precendent slows and intermittently stops

Read the "Sticky" thread at the top of the page about Speed Sensor testing and see if that helps.
TahoeDawgZ71 is offline   Reply With Quote
Unread 10-08-2012, 02:39 PM   #5
Not Yet Wild
 
Join Date: Oct 2012
Posts: 9
Default Re: 2005 Precendent slows and intermittently stops

Thanks guys. I did the speed sensor test from the sticky as well as the actual test with a meter from the maintenance manual, the sensor failed both. I have one on order, I will post an update after it is replaced.
dschron is offline   Reply With Quote
Unread 10-12-2012, 05:10 AM   #6
Not Yet Wild
 
Join Date: Oct 2012
Posts: 9
Default Re: 2005 Precendent slows and intermittently stops

Update

I received the speed sensor yesterday and installed it, it fixed my problem. Normal operation now. Thank you all for the advice and help!
dschron is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
36V resistor club car stops intermittently Electric Club Car
2005 Precendent ...no Neutral Gas Club Car
cart slows then stops Electric EZGO
EZ Go Electric "hops" and slows down and stops running Electric EZGO
2005 freedom stops while running Electric EZGO


All times are GMT -5. The time now is 11:58 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.