lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-27-2012, 11:01 AM   #1
Getting Wild
 
fabricatorjay's Avatar
Club Car
 
Join Date: Jul 2012
Location: carleton michigan
Posts: 100
Default dead battery symtoms

well my wife ran my cart dead,as in dead pushing it up the road.i charged it up and no go,found one dead battery,if i plug in the charger it clicks but the needle dont move,now if i turn on my headlights the charger kicks on wide open needle is all the way past 15,i took the wires off my lights as not to burn them up,the black wire that comes from the controller was hooked to the black wire on the light kit,the black wire is also tied in to the obc and the ground wire from battery pack that goes through the obc if i hook that black wire up to a positive terminal on my battery pack the charger kicks on past 15 again.if i unplug the charger and hook up that black wire again to a positive termanal the cart moves fine forward and reverse mind you that one battery is still dead,what the heck happened,can i remove 3 8 volt batteries and put in 2 12 volts just to see if my cart still moves and charges right without that black wire hooked up,any help is good help...........thanks jay
fabricatorjay is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-27-2012, 11:04 AM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: dead battery symtoms

what year is the cart? before you do anything..........................
shadowman is offline   Reply With Quote
Unread 10-27-2012, 11:18 AM   #3
Gone Wild
 
simple man's Avatar
E-Z-GO
 
Join Date: Aug 2011
Location: Bunnell, Florida
Posts: 2,408
Default Re: dead battery symtoms

Two questions. #1 Did everything work Ok before this happened? #2 Have you looked carefully at all your connections?
It sounds like maybe one of the battery cables lost a connection and when you turn on the lights they are completing the connection, but not to the whole battery pack. Don't turn the lights on when the charger's on as it can fry the bulbs! My first step suggestion would be to check and clean all the cable terminals and battery posts. While you are doing this I would charge the one dead battery with an automotive charger and see if it will come up. You may have to replace it!
simple man is offline   Reply With Quote
Unread 10-27-2012, 12:38 PM   #4
Getting Wild
 
fabricatorjay's Avatar
Club Car
 
Join Date: Jul 2012
Location: carleton michigan
Posts: 100
Default Re: dead battery symtoms

thanks for the replys,its a 09 presedent,i took out the bad battery and 2 good ones and put 2 12 volt batteries in it and all is working good,my charger kicked on like normal and cart runs sweet,i need 1 new 8 volt battery,thats not so bad,i just dont understand why if i hook a wire up to a positive post that is already hooked to the ground wire on the battery pack it will make things work,all but the charger kicking on full blast,i must be bypassing the obc somehow......atleast its only a battery...........
fabricatorjay is offline   Reply With Quote
Unread 10-27-2012, 12:55 PM   #5
Gone Wild
 
simple man's Avatar
E-Z-GO
 
Join Date: Aug 2011
Location: Bunnell, Florida
Posts: 2,408
Default Re: dead battery symtoms

Quote:
Originally Posted by fabricatorjay View Post
thanks for the replys,its a 09 presedent,i took out the bad battery and 2 good ones and put 2 12 volt batteries in it and all is working good,my charger kicked on like normal and cart runs sweet,i need 1 new 8 volt battery,thats not so bad,i just dont understand why if i hook a wire up to a positive post that is already hooked to the ground wire on the battery pack it will make things work,all but the charger kicking on full blast,i must be bypassing the obc somehow......atleast its only a battery...........
Cool! Sometimes things are just " simple "!
simple man is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Charging a dead battery Electric EZGO
dead battery Gas Club Car
Dead Battery Electric Club Car
battery go dead Electric EZGO
Dead Battery Electric Club Car


All times are GMT -5. The time now is 04:57 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.