lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-29-2012, 10:51 PM   #1
Not Yet Wild
 
Join Date: Oct 2012
Posts: 2
Default Kart lugs/ voltage to the motor drops

Hi there,

I am actually working on a go kart but it runs essentially the same system as some of these golf karts. The problem I'm having is somewhere between the throttle and the motor (Each battery is showing proper voltage). When I first apply throttle the voltage at the motor is initially at about 48V, but if I try to make it accelerate, the voltage drops to about 16V and won't go anywhere. I'm wondering if anyone has seen this happen before and if so, what you did to fix it.

Thanks
motoman809 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-30-2012, 04:10 AM   #2
Gone Wild
 
simple man's Avatar
E-Z-GO
 
Join Date: Aug 2011
Location: Bunnell, Florida
Posts: 2,408
Default Re: Kart lugs/ voltage to the motor drops

What kind of batteries does your kart use and is it a series motor? As with a golf cart, the first step is to make sure you have good, fully charged batteries, and all the cables are clean and tight!
simple man is offline   Reply With Quote
Unread 11-02-2012, 11:11 PM   #3
Not Yet Wild
 
Join Date: Oct 2012
Posts: 2
Default Re: Kart lugs/ voltage to the motor drops

I have fresh Optima blue top batteries and all the cables and lugs are clean. Also, it is a series motor. and I have even tried switching the throttle potentiometer with a new one.
motoman809 is offline   Reply With Quote
Unread 11-08-2012, 08:06 AM   #4
Gone Wild
Club Car
 
Join Date: Oct 2008
Location: East Texas
Posts: 318
Default Re: Kart lugs/ voltage to the motor drops

Have you load tested those batteries by chance?
basshawk84 is offline   Reply With Quote
Unread 11-08-2012, 10:34 AM   #5
ΜΟΛΩΝ ΛΑΒΕ
 
93yellowclubcar's Avatar
Club Car
 
Join Date: Nov 2012
Location: West Virginia
Posts: 4,094
Default Re: Kart lugs/ voltage to the motor drops

I agree with basshawk, do a load test on the batteries. There's always the chance that one or more of them isn't holding up under load. The problem you're describing sounds a bit like weak batteries.
93yellowclubcar is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Pack voltage drops under load but individual batts don't? Electric EZGO
F.S. - yamaha gas kart rear end, motor, wheels... Golf Carts and Parts
How to define motor lugs Electric EZGO
battery voltage drops within an hour Electric Club Car
go-kart with golf cart motor Design Center


All times are GMT -5. The time now is 09:28 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.