lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-04-2012, 09:06 PM   #1
Not Yet Wild
 
Join Date: Sep 2012
Posts: 7
Default 1989 club car no acceleration

i was driving my cart through pretty decent rough terrain when the cart lost all forward and reverse power. Noticed a little smoke coming from inside battery compartment. Think somethings wrong with the black box(computer?) inside the compartment. what should i try to fix it??
Gfreel is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-04-2012, 09:10 PM   #2
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,045
Default Re: 1989 club car no acceleration

If smoke came out of the controller it is done for. See if you can smell it, if it has a burnt electronic smell it was the source of your smoke and must be replaced.
scottyb is online now   Reply With Quote
Unread 11-04-2012, 09:15 PM   #3
Gone Wild
 
Xact1's Avatar
Club Car
 
Join Date: Jun 2009
Location: Binghamton, NY
Posts: 384
Default Re: 1989 club car no acceleration

Quote:
Originally Posted by Gfreel View Post
i was driving my cart through pretty decent rough terrain when the cart lost all forward and reverse power. Noticed a little smoke coming from inside battery compartment. Think somethings wrong with the black box(computer?) inside the compartment. what should i try to fix it??
Gfreel, you have an older resistor cart with the V glide setup. I would check the V glide box first, to see if something burned up inside. This is not uncommon on this vintage cart. I have a 1992, had the same thing happen, finally pulled the whole system out and upgraded to a controller unit.
Xact1 is offline   Reply With Quote
Unread 11-04-2012, 09:26 PM   #4
Not Yet Wild
 
Join Date: Sep 2012
Posts: 7
Default Re: 1989 club car no acceleration

My cart is 36 volt stock everything can I use the controller and solenoid off my buddy's 48volt cart he gave me and update it from the resistor could to the controller
Gfreel is offline   Reply With Quote
Unread 11-04-2012, 09:42 PM   #5
Gone Wild
 
Xact1's Avatar
Club Car
 
Join Date: Jun 2009
Location: Binghamton, NY
Posts: 384
Default Re: 1989 club car no acceleration

Well, I looked at the 'Stickys' threads, and there are indeed V-glide systems with and without solid state controllers. You should take a look at those schematics, and tell us what you have.
Xact1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2005 club car 48v limo, loss of acceleration Electric Club Car
1996 Club Car DS rough acceleration Electric Club Car
'83 club car acceleration problem Electric Club Car
1998 club car DS acceleration problems Electric Club Car
94 electric Club Car acceleration problems Electric Club Car


All times are GMT -5. The time now is 12:16 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.