lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-12-2012, 04:28 PM   #1
mcc
Not Yet Wild
 
Join Date: Nov 2012
Posts: 2
Default cart will not drive after washing

I power washed my 09 cart and now it will not drive at all. I dont think it will take a charge either... not sure what to check. Please help. Any ideas?
mcc is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-12-2012, 11:39 PM   #2
Getting Wild
 
hanny's Avatar
 
Join Date: May 2012
Posts: 111
Default Re: cart will not drive after washing

Quote:
Originally Posted by mcc View Post
I power washed my 09 cart and now it will not drive at all. I dont think it will take a charge either... not sure what to check. Please help. Any ideas?
the controllers hate water and usually will dry out the next day and work fine. you may want to put a fan drying out the controller area especially if the connector got wet going into it. good luck, i did the same thing on my 08 and took the connector off the controller dried it out and all was good again
hanny is offline   Reply With Quote
Unread 11-13-2012, 06:55 AM   #3
Gone Wild
Club Car
 
Join Date: Oct 2008
Location: East Texas
Posts: 318
Default Re: cart will not drive after washing

Take off the front seat bottom and use a leaf blower to dry everything out as best you can. It may just need to sit for a bit after that to completely dry out.
basshawk84 is offline   Reply With Quote
Unread 11-13-2012, 11:28 AM   #4
Gone Wild
 
lmswest's Avatar
 
Join Date: Jul 2012
Posts: 366
Default Re: cart will not drive after washing

Then after you blow all electrical connections out well with the leaf blower spray all connections with wd 40 . It displaces all the water..Works like a charm!
lmswest is offline   Reply With Quote
Unread 11-13-2012, 12:44 PM   #5
Not Yet Wild
 
Join Date: Sep 2012
Posts: 10
Default Re: cart will not drive after washing

Have the same problem with my gas g9 Yamaha. WD 40 huh. Will try it!
jcG9 is offline   Reply With Quote
Unread 11-13-2012, 04:11 PM   #6
Gone Wild
 
lmswest's Avatar
 
Join Date: Jul 2012
Posts: 366
Default Re: cart will not drive after washing

Wd-40 wasnt originally intended to be used as a lube. It was designed to displace water in electronics and they nailed it on their 40th try .Water displacement test 40 . Just so happened it has great lube properties as well..
Last time I gave this advice the guy attacked me saying I was being condescending. Im not, just not everyone knows that about wd 40
lmswest is offline   Reply With Quote
Unread 11-14-2012, 09:59 AM   #7
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: cart will not drive after washing

Quote:
Originally Posted by mcc View Post
I power washed my 09 cart and now it will not drive at all. I dont think it will take a charge either... not sure what to check. Please help. Any ideas?
get your controller dried out.....................................
shadowman is offline   Reply With Quote
Unread 11-14-2012, 10:09 AM   #8
Gone Wild
 
Xact1's Avatar
Club Car
 
Join Date: Jun 2009
Location: Binghamton, NY
Posts: 384
Default Re: cart will not drive after washing

Quote:
Originally Posted by lmswest View Post
Wd-40 wasnt originally intended to be used as a lube. It was designed to displace water in electronics and they nailed it on their 40th try .Water displacement test 40 . Just so happened it has great lube properties as well..
Last time I gave this advice the guy attacked me saying I was being condescending. Im not, just not everyone knows that about wd 40
An interesting bit of trivia!
Xact1 is offline   Reply With Quote
Unread 11-14-2012, 01:43 PM   #9
Gone Wild
 
Join Date: Dec 2010
Location: Ft Myers
Posts: 379
Default Re: cart will not drive after washing

Never knew that about the WD40...interesting. However it could be a double edge sword because the lubricating components attract dirt.
cmar143 is offline   Reply With Quote
Unread 11-14-2012, 02:47 PM   #10
mcc
Not Yet Wild
 
Join Date: Nov 2012
Posts: 2
Default Re: cart will not drive after washing

thank you all for all the help. Everything is dry but the cart will not do anything. any suggestions.... it will not take a charge either. maybe this problem is not from the wash but it was driving right before the power wash. what should i check or do? when i try to charge it nothing happens, the volts are reading about 50
mcc is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Washing Electric Golf Cart Electric EZGO
Washing 2006 Precendent Electric Club Car
Pressure Washing Carts Electric EZGO
washing my cart Electric Club Car
Washing Elect Cart Electric Club Car


All times are GMT -5. The time now is 05:26 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.