lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-26-2012, 09:19 PM   #1
Gone Wild
Club Car
 
Join Date: Feb 2012
Location: Indio, CA The Desert!
Posts: 1,175
Default motor slows down at full pedal

03 club car DS 48 volt , speed code 4, pedal up setting is zero.

I have the regen braking turned off, When I have the cart pedal floored, going down a local hill, I feel a slight loss of power ( it feels like the regen braking is kicking in). Then once I amthrough the hill, it feels like I am back to the normal 19.5 mph speed. Also, when this happens, i can hear a sound coming from the motor , that sounds like a rumbleing sound.

What is kicking in, to make the cart slow slightly?

Any help is appreciated.

I don't know if I need a new motor, a bearing, a centering kit, brushes?
smokey tennis shoe is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-27-2012, 09:48 AM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: motor slows down at full pedal

i wish i could help but if your sure its not the reagan braking....as far as i know that year had no issues with a centering kit so my advice would be wait for david ( tahoedawg ) see what he thinks...............................
shadowman is offline   Reply With Quote
Unread 11-27-2012, 10:10 AM   #3
Gone Wild
Club Car
 
Join Date: Feb 2012
Location: Indio, CA The Desert!
Posts: 1,175
Default Re: motor slows down at full pedal

I can't say i am sure about anything, other than I have the "pedal up" set at zero, so the regen braking does not kick in when i let off the pedal.

This only happens when i have it floored, going down hill. There is a slight loss of power ( this feels like regen braking) , and the sound I hear coming from the motor is a low sort of grumbling. Once I get thru the incline, evrything goes back to normal.

This ONLY happens under the above scenario .

ALSO you mentioned centering kit, was that specific to only certain years of carts, or certain models, or what?

When brushes need replacing, what type of symptoms are there that lets you know there is a problem, or lets you know they need replacing?
smokey tennis shoe is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Starter motor no go when gas pedal depressed Gas Club Car
98 cc full pedal shakes no speed Electric Club Car
2007 precedent stops at full pedal Electric Club Car
half way down on the pedal the motor dies Electric EZGO
Slows Down, Then Shutters at Full Pedal Electric Club Car


All times are GMT -5. The time now is 07:12 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.