lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-03-2012, 07:18 PM   #1
Not Yet Wild
 
Join Date: Nov 2012
Posts: 2
Default 2006 Precedent - Barely Moves, Batteries Charged

With key ON, selector switch on FWD, I slowly depress accelerator. Forward movement is started then stops. Relay in IP clicks and yellow charge light comes on. Selector switch is moved to REV and the same things occur, except speed is greater before everything stops. I have check voltage, which is at 50 Vdc and have attempted to reset the OBC. When following the steps for reset, the backup buzzer never shuts off. I think it is suppose to turn off after 30 seconds.
kenbob1941 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-03-2012, 08:50 PM   #2
Gone Wild
 
simple man's Avatar
E-Z-GO
 
Join Date: Aug 2011
Location: Bunnell, Florida
Posts: 2,408
Default Re: 2006 Precedent - Barely Moves, Batteries Charged

Quote:
Originally Posted by kenbob1941 View Post
With key ON, selector switch on FWD, I slowly depress accelerator. Forward movement is started then stops. Relay in IP clicks and yellow charge light comes on. Selector switch is moved to REV and the same things occur, except speed is greater before everything stops. I have check voltage, which is at 50 Vdc and have attempted to reset the OBC. When following the steps for reset, the backup buzzer never shuts off. I think it is suppose to turn off after 30 seconds.
Check your voltage when trying to move the cart. Let us know what you get.
simple man is offline   Reply With Quote
Unread 12-05-2012, 10:11 PM   #3
Not Yet Wild
 
Join Date: Nov 2012
Posts: 2
Default Re: 2006 Precedent - Barely Moves, Batteries Charged

Quote:
Originally Posted by simple man View Post
Check your voltage when trying to move the cart. Let us know what you get.
The voltage is fairly stable. Might fluctuate a volt or two.
kenbob1941 is offline   Reply With Quote
Reply

Tags
no movement, reset, yellow light
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Barely Moves Electric EZGO
g1 slowly moves-but batteries charged Electric Yamaha
97 Club Car-New batteries-"jerks,clicks,&barely moves" Electric Club Car
01 EZ GO Electric barely moves. Electric EZGO
Press the gas but barely moves now Electric EZGO


All times are GMT -5. The time now is 07:36 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.