lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-09-2012, 03:23 PM   #21
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,053
Default Re: installed D & D 5020 and lost speed

Their website does have some conflicting information... When I quote those charts to their engineers they turn blue and flop on the floor

I can only say what others have told me. I have not run that particular motor in my cart.
It could be you are starving the motor for amperage. This could be the controller, the cables, the batteries, or all of the above.

Hope this helps
scottyb is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-09-2012, 03:29 PM   #22
Gone Wild
 
Join Date: Jul 2012
Posts: 912
Default Re: installed D & D 5020 and lost speed

What do you use the cart for anyway and why do you need more torque?

Also, what motor was your stock motor? If it is an Advance motor there are several vendors that offer a core exchange and you can usually get a new motor in the $2-300 range, rather than $500 plus.

Also, did you know that you could have a dealer reprogram your stock contoller that might get you to around 20-22 MPH on your stock motor?
Speedchaser is offline   Reply With Quote
Unread 12-09-2012, 03:41 PM   #23
Not Yet Wild
 
Join Date: Oct 2012
Posts: 43
Default Re: installed D & D 5020 and lost speed

Cant say enoght how I appreciate the info,,,,just came inside FYI, cart goes 10mph wide open,,,forward and reverse,,, go figure? I use this cart exclusively for hunting. I have some steep hills and although torque is A number 1, descent speed is okay. I will have to say the 10mph is fine with me. Would I acually get more torque with a controller upgrade? and do yall know what amp my stock controller is by any chance?
angriffnole is offline   Reply With Quote
Unread 12-09-2012, 03:44 PM   #24
friends call me Boke
 
bokeasmowl's Avatar
Yamaha
 
Join Date: Apr 2008
Location: Smithfield, North Carolina
Posts: 7,773
Default Re: installed D & D 5020 and lost speed

They were probably thinking why are you calling us when you should contact the eBay yo yo you bought it from. I've dealt with DnD only and have never had any ill responses from them. Then again I purchase directly from them and not some motor rebuilder. There's no telling what that guy could have done to that motor.
bokeasmowl is offline   Reply With Quote
Unread 12-09-2012, 03:52 PM   #25
Not Yet Wild
 
Join Date: Oct 2012
Posts: 43
Default Re: installed D & D 5020 and lost speed

bokeasmowl, they never new I had even bought a motor anyhwere else. I spoke with them way before I even found this on ebay. Now, I did call and ask about the motor bumper after i bought on ebay. All i asked Jeff was,,,does this model motor need a bumper and he said no. The rudeness that started was way before my purchase and was actually when I was planning on buying from D and D. I would never expect D and D to spend time answering questions about someting I bought somewhere else. If the gracious help of people on this sight does not do the trick, I will call it a loss and start over. What caused me to look elsewhere was the attitude Jeff had from the start. I dont need a Candy coater, But i do expect a little courtesy thrown my way when I throw cash your way.
angriffnole is offline   Reply With Quote
Unread 12-09-2012, 03:54 PM   #26
Gone Wild
 
Join Date: Jul 2012
Posts: 912
Default Re: installed D & D 5020 and lost speed

My opinion is that you will not reap the torque benefits without a controller upgrade and that stock is most likely a Curtis 1510A-5251 controller and rated at 250 amps.
Speedchaser is offline   Reply With Quote
Unread 12-09-2012, 03:56 PM   #27
Not Yet Wild
 
Join Date: Oct 2012
Posts: 43
Default Re: installed D & D 5020 and lost speed

speedchaser, do you think the clicking I hear from the driver side rear tire is coming from not having a motor bumper on the new motor?
angriffnole is offline   Reply With Quote
Unread 12-09-2012, 03:56 PM   #28
Gone Wild
 
Join Date: Jul 2012
Posts: 912
Default Re: installed D & D 5020 and lost speed

Quote:
Originally Posted by bokeasmowl View Post
They were probably thinking why are you calling us when you should contact the eBay yo yo you bought it from. I've dealt with DnD only and have never had any ill responses from them. Then again I purchase directly from them and not some motor rebuilder. There's no telling what that guy could have done to that motor.
That is probably true but a business will lose more from one person saying bad stuff than they would gain from 100 people saying good stuff.
Speedchaser is offline   Reply With Quote
Unread 12-09-2012, 04:17 PM   #29
Gone Wild
 
Join Date: Jul 2012
Posts: 912
Default Re: installed D & D 5020 and lost speed

Quote:
Originally Posted by angriffnole View Post
speedchaser, do you think the clicking I hear from the driver side rear tire is coming from not having a motor bumper on the new motor?
Not necessarily, i have noticed clicking from one wheel on two different carts, I think it could be the wheel itself.

Check out these packages from EV Drives, have some good info on your motor too. Great to do business with. http://wwwevdrivescom/category_s/186...show=20&page=1
Speedchaser is offline   Reply With Quote
Unread 12-09-2012, 08:25 PM   #30
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,966
Default Re: installed D & D 5020 and lost speed

angriffnole....... Let's back up... What's the serial number for your cart?
TahoeDawgZ71 is offline   Reply With Quote
Reply

Tags
motor 170-502-0002
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Lost of speed and climbing ability Electric Club Car
Cart lost speed and won't climb Electric Club Car
08 Precedent lost speed Electric Club Car
ezgo speed lost Electric EZGO
Lost low speed on my 98 electric cart Electric Club Car


All times are GMT -5. The time now is 05:17 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.